summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-11-11 21:23:08 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-11-11 21:23:08 -0300
commitad233fd5e162339df77ab44243d2653baab7ebfd (patch)
tree96a7f837ec552614493f07dd9879d0bed4916234 /Makefile
parent650750cae5039d1a0ece091fe84e7bd2a17eca00 (diff)
Configure local user also
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f3b7afe..5031c03 100644
--- a/Makefile
+++ b/Makefile
@@ -30,6 +30,11 @@ check:
exit 1 ;\
fi
+# Add the hackers repo to the local clone
+install-local:
+ git remote add git git:hackers.git
+ cat ssh_config >>$(HOME)/.ssh/config
+
# Create the hackers.git bare repo and clone as .ssh
# Then create needed symlinks and add hooks to hackers.git
install: check
@@ -41,4 +46,4 @@ install: check
chmod 600 .ssh/authorized_keys && \
ln -s $(PREFIX)/.ssh/git-hooks/* hackers.git/hooks/ && \
ln -s $(PREFIX)/.ssh/git-shell-commands && \
- chown -R $(USER):$(USER) $(PREFIX)
+ chown -R $(USER):$(USER) $(PREFIX)