summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2022-04-12 20:13:48 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2022-04-12 21:27:06 -0400
commit82a39269aa8fb63a6f9abc7246c20d79ba5447a2 (patch)
tree32d0e9b5a358d7ebfd06a72946c9e562e054a3bf /Makefile
parent9f2356b34595b9663c1b25674607d0c981461f2b (diff)
upstream parabola changes from PKGBUILD
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f408ba9..b084c00 100644
--- a/Makefile
+++ b/Makefile
@@ -41,6 +41,9 @@ GOPATH = $(abspath $(topoutdir)/go)
go_variables := $(shell go env|cut -d= -f1)
$(foreach v,$(go_variables),$(if $(filter GO% CGO%,$v),$(eval $v ?=),$(eval go_$v ?=)))
go_env = $(foreach v,$(go_variables),$(if $(go_$v),$v='$(go_$v)',$(if $($v),$v='$($v)')))
+# FIXME: fails to build on parabola since ~2019, without this change:
+# GO111MODULE=auto allows mixing module-type and non-module-type go packages
+go_env += GO111MODULE=auto
#
# Generate (pre-tarball)