summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-06-15 15:55:36 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-06-15 15:55:36 -0400
commit8736082d1b0eb9a1af8265bc443f2058550e9925 (patch)
tree2cf7e7af383c61b8772ced9c66b8a2b5bea255ac /bin
parenta7ed703d2d983b0b7fd796fba60a2592e9edd262 (diff)
do away with pgp-get-keyid-by-uid
Diffstat (limited to 'bin')
-rwxr-xr-xbin/pacman-make-keyring3
-rwxr-xr-xbin/pgp-get-keyid-by-uid5
2 files changed, 2 insertions, 6 deletions
diff --git a/bin/pacman-make-keyring b/bin/pacman-make-keyring
index 3951361..589984d 100755
--- a/bin/pacman-make-keyring
+++ b/bin/pacman-make-keyring
@@ -81,6 +81,7 @@ $(cachedir)/deps.mk: ${users} $(var)outputdir $(var)cachedir $(var)KEYRING_NAME|
{ \
echo $(outputdir)/${KEYRING_NAME}.gpg: $$($(bin)/pgp-list-keyids | sed -r 's|(\S+) .*|$$(cachedir)/keys/\1.asc|') && \
echo $(cachedir)/stamp.ownertrust: $$($(bin)/pgp-list-keyids | sed -rn 's|^(trusted/\S+) .*|$$(cachedir)/keys/\1.asc|p') && \
+ $(bin)/pgp-list-keyids | sed -rn 's|^trusted/(\S+) (.*)|keyid.\1 = \2|p' && \
$(bin)/uid-map | sed 's|.*|trusted:&\nsecondary:&\nrevoked:&|' | sed -r 's|(.*):(.*):(.*)|$$(cachedir)/keys/\1/\3.asc: $$(yamldir)/\2.yml|' && \
:; }> $@
-include $(cachedir)/deps.mk
@@ -114,7 +115,7 @@ $(cachedir)/stamp.gpg-init: $(cachedir)/txt.gpg-init $(var)GPG | $(cachedir)/gpg
# The appropriate ${uid}.yml file is added as a dependency to
# ${username}.yml by deps.mk
-keyid=$$($(bin)/pgp-get-keyid-by-uid $(patsubst %.yml,%,$(notdir $(filter %.yml,$^))))
+keyid=$(keyid.$(patsubst %.asc,%,$(notdir $@)))
# In 'update-keys', this is the 'master-keyids' loop
$(outputdir)/${KEYRING_NAME}-trusted: ${users} | $(outputdir)
diff --git a/bin/pgp-get-keyid-by-uid b/bin/pgp-get-keyid-by-uid
deleted file mode 100755
index 94a869d..0000000
--- a/bin/pgp-get-keyid-by-uid
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/usr/bin/env ruby
-# Usage: pgp-get-keyid-by-uid {uid}
-
-load "#{File.dirname(__FILE__)}/common.rb"
-puts load_user_yaml("#{cfg["yamldir"]}/#{ARGV[0]}.yml")["pgp_keyid"]