summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.each.head
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-05-31 00:03:19 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-05-31 00:03:19 -0400
commitdb898def01041ab564c78331a31aea99165c8d36 (patch)
tree3431e3c625608585bfa094e744ae1bdc5d120a2b /build-aux/Makefile.each.head
parent68affbbe3a2258510f48c62400cc95ad042c959d (diff)
fix: We must set std.clean_files before std reads it!
Diffstat (limited to 'build-aux/Makefile.each.head')
-rw-r--r--build-aux/Makefile.each.head/00-dist.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/build-aux/Makefile.each.head/00-dist.mk b/build-aux/Makefile.each.head/00-dist.mk
new file mode 100644
index 0000000..a094305
--- /dev/null
+++ b/build-aux/Makefile.each.head/00-dist.mk
@@ -0,0 +1,20 @@
+# Copyright (C) 2015-2016 Luke Shumaker
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+ifeq ($(outdir),$(topoutdir))
+std.clean_files += $(addprefix $(dist.pkgname)-*,$(dist.exts) .tar /)
+endif
+
+$(outdir)/dist: $(addprefix $(topoutdir)/$(dist.pkgname)-$(dist.version),$(dist.exts))