summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.each.tail/00-dist.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-17 02:20:31 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-17 02:22:05 -0500
commitdd98e1c994520acc817d3dfa651ccf291827630d (patch)
tree8a5badbc1b1135cfb5357ea3aca5e82d4c5f0578 /build-aux/Makefile.each.tail/00-dist.mk
parent2d33bd2f34f011c4f025a073b50d536f6a66a4db (diff)
Backport fixes from work on parabola-hackers.git.
- core: Actually support at.Makefile; how it set the internal variable _at.MAKEFILE_LIST was broken if $(at.Makefile) != Makefile - mod: dist: * Don't try to distribute $(files.src.int) files. * Add a comment noting that the lack of the `-P` flag to `cp` is not a bug. - mod: gitfiles: * Correctly list files in $(topsrcdir). * Also enumerate files in git submodules.
Diffstat (limited to 'build-aux/Makefile.each.tail/00-dist.mk')
-rw-r--r--build-aux/Makefile.each.tail/00-dist.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/build-aux/Makefile.each.tail/00-dist.mk b/build-aux/Makefile.each.tail/00-dist.mk
index bc2a3d5..b023e80 100644
--- a/build-aux/Makefile.each.tail/00-dist.mk
+++ b/build-aux/Makefile.each.tail/00-dist.mk
@@ -1 +1 @@
-_dist.files := $(strip $(_dist.files) $(call at.addprefix,$(srcdir),$(files.src)))
+_dist.files := $(strip $(_dist.files) $(call at.addprefix,$(srcdir),$(filter-out $(files.src.int),$(files.src))))