summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.each.tail/00-mod.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-08-17 01:33:02 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-08-17 01:33:02 -0400
commitf97cfec567d54e883e1b868714b6beee5420ba2d (patch)
treef20fe2a24929c286a5dbf62d2dcbf53d5c4d2f0b /build-aux/Makefile.each.tail/00-mod.mk
parent88d181c25d2f99f8b510afe2f2cc7e1ba1fa012c (diff)
(systemd) more
Diffstat (limited to 'build-aux/Makefile.each.tail/00-mod.mk')
-rw-r--r--build-aux/Makefile.each.tail/00-mod.mk20
1 files changed, 10 insertions, 10 deletions
diff --git a/build-aux/Makefile.each.tail/00-mod.mk b/build-aux/Makefile.each.tail/00-mod.mk
index 6346173..dc1a2fe 100644
--- a/build-aux/Makefile.each.tail/00-mod.mk
+++ b/build-aux/Makefile.each.tail/00-mod.mk
@@ -13,27 +13,27 @@
# You should have received a copy of the GNU Affero General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-$(outdir)/at-variables $(outdir)/at-variables-local: _mod.VARIABLES := $(filter-out $(call _mod.quote-pattern,$(_at.VARIABLES)),$(.VARIABLES))
+$(outdir)/at-variables $(outdir)/at-variables-local: _mod.VARIABLES := $(filter-out $(call quote.pattern,$(_at.VARIABLES)),$(.VARIABLES))
$(outdir)/at-variables-global:
- @printf '%s\n' $(call _mod.quote-shell-each,$(sort $(.VARIABLES)))
+ @printf '%s\n' $(call quote.shell-each,$(sort $(.VARIABLES)))
$(outdir)/at-variables-local:
- @printf '%s\n' $(call _mod.quote-shell-each,$(sort $(_mod.VARIABLES)))
+ @printf '%s\n' $(call quote.shell-each,$(sort $(_mod.VARIABLES)))
$(outdir)/at-variables $(outdir)/at-values:
- @printf '%s\n' $(call _mod.quote-shell-each,$(sort $(.VARIABLES),$(_mod.VARIABLES)))
+ @printf '%s\n' $(call quote.shell-each,$(sort $(.VARIABLES),$(_mod.VARIABLES)))
$(outdir)/at-variables/%:
- @printf '%s\n' $(call _mod.quote-shell,$($*))
+ @printf '%s\n' $(call quote.shell,$($*))
$(outdir)/at-values/%:
- @printf '%s\n' $(call _mod.quote-shell,$(value $*))
+ @printf '%s\n' $(call quote.shell,$(value $*))
.PHONY: $(addprefix $(outdir)/, at-variables-global at-variables-local at-variables at-values)
at.targets += $(addprefix $(outdir)/, at-variables-global at-variables-local at-variables at-values at-variables/% at-values/%)
$(outdir)/at-modules:
@printf 'Autothing modules used in this project:\n'
- @printf ' - %s\n' $(foreach _mod.tmp,$(_mod.modules),$(call _mod.quote-shell,$(_mod.tmp) $(mod.$(_mod.tmp).description)))|column -t -s $$'\t'
+ @printf ' - %s\n' $(foreach _mod.tmp,$(_mod.modules),$(call quote.shell,$(_mod.tmp) $(mod.$(_mod.tmp).description)))|column -t -s $$'\t'
$(addprefix $(outdir)/at-modules/,$(_mod.modules)): $(outdir)/at-modules/%:
- @printf 'Name : %s\n' $(call _mod.quote-shell,$*)
- @printf 'Description : %s\n' $(call _mod.quote-shell,$(mod.$*.description))
- @echo 'Contains Files :' $(call _mod.quote-shell-each,$(call at.relto,$(topsrcdir),$(sort $(mod.$*.files) $(wildcard $(topsrcdir)/build-aux/Makefile.*/??-$*.mk))))
+ @printf 'Name : %s\n' $(call quote.shell,$*)
+ @printf 'Description : %s\n' $(call quote.shell,$(mod.$*.description))
+ @echo 'Contains Files :' $(call quote.shell-each,$(call at.relto,$(topsrcdir),$(sort $(mod.$*.files) $(wildcard $(topsrcdir)/build-aux/Makefile.*/??-$*.mk))))
@echo 'Depends on :' $(mod.$*.depends)
$(outdir)/at-noop: