summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.each.tail/00-var.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 01:33:24 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 18:38:13 -0500
commit16e8d3b92b5e35a5eaee40a7b7fc0279c342886a (patch)
tree8c8f2d62d1aae66ec44aed6c3765a565034c0f01 /build-aux/Makefile.each.tail/00-var.mk
parent36e62cbb6bdb17c318c00ee55f8049930438aa83 (diff)
(libretools) Fix bugs in autothing.
Some of these are that I hadn't originally designed autothing v3 to work with --warn-undefined-variables. Others are just straight-up bugs from inadequate testing.
Diffstat (limited to 'build-aux/Makefile.each.tail/00-var.mk')
-rw-r--r--build-aux/Makefile.each.tail/00-var.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/build-aux/Makefile.each.tail/00-var.mk b/build-aux/Makefile.each.tail/00-var.mk
index c2fd9d7..954defb 100644
--- a/build-aux/Makefile.each.tail/00-var.mk
+++ b/build-aux/Makefile.each.tail/00-var.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016 Luke Shumaker
+# Copyright (C) 2016-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -13,10 +13,10 @@
# You should have received a copy of the GNU Affero General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-mod.var.depends += quote write-ifchanged
+mod.var.depends += files quote write-ifchanged
$(outdir)/.var.%: _var.FORCE
@printf '%s' $(call quote.shell,$($*)) | sed 's/^/#/' | $(WRITE_IFCHANGED) $@
-include $(wildcard $(outdir)/.var.*)
-at.targets += $(addprefix $(outdir)/,.var.%)
+files.out.int += .var.*