summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.each.tail/10-nested.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-08-10 11:22:38 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-08-10 11:22:38 -0400
commit88d181c25d2f99f8b510afe2f2cc7e1ba1fa012c (patch)
tree8034e6048fcf1e96d8eb79dcdaac375891caaa87 /build-aux/Makefile.each.tail/10-nested.mk
parent2d47b10c0a19c9f986d2b1c4e5a06d8a49d36096 (diff)
(systemd) fix build system
Diffstat (limited to 'build-aux/Makefile.each.tail/10-nested.mk')
-rw-r--r--build-aux/Makefile.each.tail/10-nested.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/build-aux/Makefile.each.tail/10-nested.mk b/build-aux/Makefile.each.tail/10-nested.mk
index e9d02ca..5e5a40b 100644
--- a/build-aux/Makefile.each.tail/10-nested.mk
+++ b/build-aux/Makefile.each.tail/10-nested.mk
@@ -13,7 +13,8 @@
# You should have received a copy of the GNU Affero General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-$(addprefix $(outdir)/,$(nested.targets)): $(outdir)/%: $(addsuffix /%,$(call at.addprefix,$(outdir),$(nested.subdirs)))
+$(eval $(foreach _tmp.nested,$(nested.targets),\
+ $$(outdir)/$(_tmp.nested): $$(addsuffix /$(_tmp.nested),$$(call at.addprefix,$$(outdir),$$(nested.subdirs)))$(at.nl)))
.PHONY: $(addprefix $(outdir)/,$(nested.targets))
at.subdirs += $(nested.subdirs)