summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.each.tail/10-nested.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-16 22:27:12 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-16 22:27:12 -0500
commita6170ec03bc3853b697c14ce93c707cb94da4baf (patch)
treeaab138a77dd843f05fdcc83e8ca2081ba41d71df /build-aux/Makefile.each.tail/10-nested.mk
parent71e4583a0c3b24cc55cc1701f3ed129baa45d0b7 (diff)
parent2d33bd2f34f011c4f025a073b50d536f6a66a4db (diff)
Merge remote-tracking branch 'r-autothing/v3/master'
# Conflicts: # .gitignore # Makefile # README.md # build-aux/Makefile.README.txt
Diffstat (limited to 'build-aux/Makefile.each.tail/10-nested.mk')
-rw-r--r--build-aux/Makefile.each.tail/10-nested.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/build-aux/Makefile.each.tail/10-nested.mk b/build-aux/Makefile.each.tail/10-nested.mk
new file mode 100644
index 0000000..5e5a40b
--- /dev/null
+++ b/build-aux/Makefile.each.tail/10-nested.mk
@@ -0,0 +1,20 @@
+# Copyright (C) 2016 Luke Shumaker
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+$(eval $(foreach _tmp.nested,$(nested.targets),\
+ $$(outdir)/$(_tmp.nested): $$(addsuffix /$(_tmp.nested),$$(call at.addprefix,$$(outdir),$$(nested.subdirs)))$(at.nl)))
+.PHONY: $(addprefix $(outdir)/,$(nested.targets))
+
+at.subdirs += $(nested.subdirs)