summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.head.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-05-29 18:39:41 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-05-29 18:39:41 -0400
commit0b3959406003cb61c9d10e2f1d45c755ec700392 (patch)
tree36422bad2a636f3144219b4801db5ae54b3cd514 /build-aux/Makefile.head.mk
parent8441649be887b54222d52fb9e69247c9012acff2 (diff)
add checks that top{src,out}dir are set
Diffstat (limited to 'build-aux/Makefile.head.mk')
-rw-r--r--build-aux/Makefile.head.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/build-aux/Makefile.head.mk b/build-aux/Makefile.head.mk
index e5ef379..c680f41 100644
--- a/build-aux/Makefile.head.mk
+++ b/build-aux/Makefile.head.mk
@@ -16,6 +16,13 @@
# This bit only gets evaluated once, at the very beginning
ifeq ($(_at.NO_ONCE),)
+ifeq ($(topsrcdir),)
+$(error topsrcdir must be set before including Makefile.head.mk)
+endif
+ifeq ($(topoutdir),)
+$(error topoutdir must be set before including Makefile.head.mk)
+endif
+
_at.noslash = $(patsubst %/.,%,$(patsubst %/,%,$1))
# These are all $(call _at.func,parent,child)
#_at.relto = $(if $2,$(shell realpath -sm --relative-to='$1' $2))