summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.head.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-17 01:36:54 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-17 01:46:45 -0500
commit1ff424c47193173b24d997293f8b0b0c4efcdd48 (patch)
tree034b64efea80bdf97a5413f6bd0b66fe6bec71c2 /build-aux/Makefile.head.mk
parenta6170ec03bc3853b697c14ce93c707cb94da4baf (diff)
Build against newer versions of libraries.
Diffstat (limited to 'build-aux/Makefile.head.mk')
-rw-r--r--build-aux/Makefile.head.mk8
1 files changed, 3 insertions, 5 deletions
diff --git a/build-aux/Makefile.head.mk b/build-aux/Makefile.head.mk
index e6b4a19..33ef9c1 100644
--- a/build-aux/Makefile.head.mk
+++ b/build-aux/Makefile.head.mk
@@ -13,8 +13,9 @@
# You should have received a copy of the GNU Affero General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
+at.Makefile ?= Makefile
_at.MAKEFILE_LIST ?=
-_at.MAKEFILE_LIST := $(strip $(_at.MAKEFILE_LIST) $(abspath $(lastword $(filter-out %.mk,$(MAKEFILE_LIST)))))
+_at.MAKEFILE_LIST := $(strip $(_at.MAKEFILE_LIST) $(lastword $(filter %/$(at.Makefile),$(abspath $(MAKEFILE_LIST)))))
# This bit only gets evaluated once, at the very beginning
ifeq ($(origin _at.NO_ONCE),undefined)
@@ -86,9 +87,6 @@ define at.nl
endef
-# External configuration ###############################################
-at.Makefile ?= Makefile
-
# Include modules ######################################################
include $(sort $(wildcard $(topsrcdir)/build-aux/Makefile.once.head/*.mk))
_at.tmp_targets =
@@ -102,7 +100,7 @@ endif # _at.NO_ONCE
outdir := $(call _at.path,$(dir $(lastword $(_at.MAKEFILE_LIST))))
ifeq ($(call _at.is_subdir,$(topoutdir),$(outdir)),)
-$(error Autothing: not a subdirectory of topoutdir=$(topoutdir): $(outdir))
+$(error Autothing: not a subdirectory of topoutdir=«$(topoutdir)»: «$(outdir)»)
endif
# Don't use at.out2src because we *know* that $(outdir) is inside $(topoutdir),