summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.head.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-08-08 01:09:59 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-08-08 01:09:59 -0400
commitbf8f76973a833659ce4ac730c4918c382192d3e0 (patch)
tree6e3e78da593c4d06a1d23ed61a614c947adbb618 /build-aux/Makefile.head.mk
parent8a5ecbb4fcaf0d9864074666a45d9263b73f31b8 (diff)
(systemd) speed up
Diffstat (limited to 'build-aux/Makefile.head.mk')
-rw-r--r--build-aux/Makefile.head.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/build-aux/Makefile.head.mk b/build-aux/Makefile.head.mk
index 8213043..105432c 100644
--- a/build-aux/Makefile.head.mk
+++ b/build-aux/Makefile.head.mk
@@ -47,6 +47,10 @@ _at.addprefix = $(call _at.path,$(if $(filter-out /%,$2),$1/$2,$2))
_at.rest = $(wordlist 2,$(words $1),$1)
_at.reverse = $(if $1,$(call _at.reverse,$(_at.rest))) $(firstword $1)
+_at.target_variable = $(_at.target_variable.$(flavor $2))
+_at.target_variable.recursive = $1: private $2 = $(subst $(at.nl),$$(at.nl),$(value $2))
+_at.target_variable.simple = $1: private $2 := $$($2)
+
# Sanity checking ######################################################
ifeq ($(filter undefine,$(.FEATURES)),)
$(error Autothing: We need a version of Make that supports 'undefine')
@@ -61,8 +65,6 @@ ifneq ($(call _at.is_strict_subdir,$(topoutdir),$(topsrcdir)),)
$(error Autothing: topsrcdir=$(topsrcdir) must not be a subdirectory of topoutdir=$(topoutdir))
endif
-# Internal setup #######################################################
-
# External provisions ##################################################
# These 4 functions are all $(call _at.func,parent,child)