summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/00-var.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 01:33:24 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 18:38:13 -0500
commit16e8d3b92b5e35a5eaee40a7b7fc0279c342886a (patch)
tree8c8f2d62d1aae66ec44aed6c3765a565034c0f01 /build-aux/Makefile.once.head/00-var.mk
parent36e62cbb6bdb17c318c00ee55f8049930438aa83 (diff)
(libretools) Fix bugs in autothing.
Some of these are that I hadn't originally designed autothing v3 to work with --warn-undefined-variables. Others are just straight-up bugs from inadequate testing.
Diffstat (limited to 'build-aux/Makefile.once.head/00-var.mk')
-rw-r--r--build-aux/Makefile.once.head/00-var.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/build-aux/Makefile.once.head/00-var.mk b/build-aux/Makefile.once.head/00-var.mk
index 1f50f21..7c9e6ff 100644
--- a/build-aux/Makefile.once.head/00-var.mk
+++ b/build-aux/Makefile.once.head/00-var.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016 Luke Shumaker
+# Copyright (C) 2016-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -20,14 +20,17 @@ define mod.var.doc
# Outputs:
# Target : `$(outdir)/.var.%`
# Directory variable: `at.targets`
+# Directory variable: `var.`
#
# It's a well-known secret that many files generated by a Makefile vary with
# the values of particular variables, but that GNU Make can't track these
# dependencies. Well, with some cleverness, it actually can!
#
# With this module, to depend on the value of a variable, depend on
-# `$(outdir)/.var.VARNAME`.
+# `$(outdir)/.var.VARNAME`, or `$(var.)VARNAME` for short.
endef
mod.var.doc := $(value mod.var.doc)
+var. = $(patsubst ./%,%,$(outdir)/.var.)
+
.PHONY: _var.FORCE