summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/00-var.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-10-28 12:45:33 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-10-28 12:45:33 -0400
commit95d18493a5d3399993053b94cb1fc4542699f884 (patch)
treed315483cfbdeb297e499ec6b09d1255ea43d3643 /build-aux/Makefile.once.head/00-var.mk
parentab69b8e9b4666ba2ad89a27b07b6944feb82eadb (diff)
(systemd) Autothing documentation
Diffstat (limited to 'build-aux/Makefile.once.head/00-var.mk')
-rw-r--r--build-aux/Makefile.once.head/00-var.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/build-aux/Makefile.once.head/00-var.mk b/build-aux/Makefile.once.head/00-var.mk
index d1e537e..636bbb0 100644
--- a/build-aux/Makefile.once.head/00-var.mk
+++ b/build-aux/Makefile.once.head/00-var.mk
@@ -14,5 +14,19 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
mod.var.description = Depend on the values of variables
+define mod.var.doc
+# Inputs:
+# (user-defined)
+# Outputs:
+# Target : `$(outdir)/.var.%`
+# Directory variable: `at.targets`
+#
+# It's a well-known secret that many files generated by a Makefile vary with
+# the values of particular variables, but that GNU Make can't track these
+# dependencies. Well, with some cleverness, it actually can!
+#
+# With this module, to depend on the value of a variable, depend on
+# `$(outdir)/.var.VARNAME`.
+endef
.PHONY: _var.FORCE