summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/10-nested.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-10-28 12:45:33 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-10-28 12:45:33 -0400
commit95d18493a5d3399993053b94cb1fc4542699f884 (patch)
treed315483cfbdeb297e499ec6b09d1255ea43d3643 /build-aux/Makefile.once.head/10-nested.mk
parentab69b8e9b4666ba2ad89a27b07b6944feb82eadb (diff)
(systemd) Autothing documentation
Diffstat (limited to 'build-aux/Makefile.once.head/10-nested.mk')
-rw-r--r--build-aux/Makefile.once.head/10-nested.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/build-aux/Makefile.once.head/10-nested.mk b/build-aux/Makefile.once.head/10-nested.mk
index af9fdf7..72e15ab 100644
--- a/build-aux/Makefile.once.head/10-nested.mk
+++ b/build-aux/Makefile.once.head/10-nested.mk
@@ -14,5 +14,31 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
mod.nested.description = Easy nested .PHONY targets
+define mod.nested.doc
+# Inputs:
+# - Global variable : `nested.targets`
+# - Directory variable : `nested.subdirs`
+# Outputs:
+# - .PHONY Targets : `$(addprefix $(outdir)/,$(nested.targets))`
+# - Variable : `at.subdirs`
+#
+# The Autothing `at.subdirs` slates a subdirectory's Makefile for inclusion,
+# but doesn't help with recursive targets like `all`, `install`, or `clean`,
+# which one would expect to descend into subdirectories. Enter `nested`:
+# Define a global list of targets that are recursive/nested, and then in each
+# directory define a list of subdirectries that one would expect them to
+# recurse into.
+#
+# Directories added to `nested.subdirs` are automatically added to `at.subdirs`
+# during the each.tail phase.
+#
+# It may help to think of at.subdirs and nested.subdirs in terms of their
+# Automake conterparts:
+#
+# | Autothing | GNU Automake |
+# +----------------+--------------+
+# | at.subdirs | DIST_SUBDIRS |
+# | nested.subdirs | SUBDIRS |
+endef
nested.targets ?=