summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/10-std.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-05-29 17:05:41 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-05-29 17:05:41 -0400
commit85c37c0e6f8ebf9d816f984a3499d856a2e708b1 (patch)
tree548f4673bcb1e5084efc04094114b3fd5a31e41c /build-aux/Makefile.once.head/10-std.mk
parent44595e16ebcde42a730d927a0f7b563feef084a3 (diff)
tidy up
Diffstat (limited to 'build-aux/Makefile.once.head/10-std.mk')
-rw-r--r--build-aux/Makefile.once.head/10-std.mk12
1 files changed, 9 insertions, 3 deletions
diff --git a/build-aux/Makefile.once.head/10-std.mk b/build-aux/Makefile.once.head/10-std.mk
index b3d7c4a..3e058ec 100644
--- a/build-aux/Makefile.once.head/10-std.mk
+++ b/build-aux/Makefile.once.head/10-std.mk
@@ -15,9 +15,7 @@
# Declare the default target
all: build
-.PHONY: all
-
-DESTDIR ?=
+.PHONY: all noop
# Standard creative PHONY targets
at.phony += build install installdirs
@@ -31,3 +29,11 @@ at.dirlocal += std.out_files
at.dirlocal += std.sys_files
at.dirlocal += std.clean_files
at.dirlocal += std.slow_files
+
+# User configuration
+
+DESTDIR ?=
+
+RM ?= rm -f
+RMDIR_P ?= rmdir -p
+TRUE ?= true