summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/zz-mod.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-10-28 12:45:33 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-10-28 12:45:33 -0400
commit95d18493a5d3399993053b94cb1fc4542699f884 (patch)
treed315483cfbdeb297e499ec6b09d1255ea43d3643 /build-aux/Makefile.once.head/zz-mod.mk
parentab69b8e9b4666ba2ad89a27b07b6944feb82eadb (diff)
(systemd) Autothing documentation
Diffstat (limited to 'build-aux/Makefile.once.head/zz-mod.mk')
-rw-r--r--build-aux/Makefile.once.head/zz-mod.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/build-aux/Makefile.once.head/zz-mod.mk b/build-aux/Makefile.once.head/zz-mod.mk
index 732f1e1..1b12a2f 100644
--- a/build-aux/Makefile.once.head/zz-mod.mk
+++ b/build-aux/Makefile.once.head/zz-mod.mk
@@ -15,6 +15,28 @@
mod.mod.description = Display information about Autothing modules
mod.mod.depends += quote
+define mod.mod.doc
+# Inputs:
+# - Files : `$(topsrcdir)/build-aux/Makefile.*/??-*.mk`
+# - Global variable : `mod.*.name`
+# - Global variable : `mod.*.description`
+# - Global variable : `mod.*.depends`
+# - Global variable : `mod.*.files`
+# - Global variable : `mod.*.doc`
+# Outputs:
+# - Directory variable : `at.targets`
+# - .PHONY Target : `$(outdir)/at-variables-local`
+# - .PHONY Target : `$(outdir)/at-variables-global`
+# - .PHONY Target : `$(outdir)/at-variables`
+# - .PHONY Target : `$(outdir)/at-variables/%`
+# - .PHONY Target : `$(outdir)/at-values`
+# - .PHONY Target : `$(outdir)/at-values/%`
+# - .PHONY Target : `$(outdir)/at-modules`
+# - .PHONY Target : `$(outdir)/at-modules/%`
+# - .PHONY Target : `$(outdir)/at-noop`
+#
+# TODO: prose documentation
+endef
# The trickery that is _mod.empty/_mod.space is from ยง6.2 of the GNU Make
# manual, "The Two Flavors of Variables".