summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 01:33:24 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 18:38:13 -0500
commit16e8d3b92b5e35a5eaee40a7b7fc0279c342886a (patch)
tree8c8f2d62d1aae66ec44aed6c3765a565034c0f01 /build-aux/Makefile.once.head
parent36e62cbb6bdb17c318c00ee55f8049930438aa83 (diff)
(libretools) Fix bugs in autothing.
Some of these are that I hadn't originally designed autothing v3 to work with --warn-undefined-variables. Others are just straight-up bugs from inadequate testing.
Diffstat (limited to 'build-aux/Makefile.once.head')
-rw-r--r--build-aux/Makefile.once.head/00-var.mk7
-rw-r--r--build-aux/Makefile.once.head/10-dist.mk8
-rw-r--r--build-aux/Makefile.once.head/10-files.mk37
-rw-r--r--build-aux/Makefile.once.head/10-gitfiles.mk (renamed from build-aux/Makefile.once.head/00-gitfiles.mk)0
-rw-r--r--build-aux/Makefile.once.head/10-gnuconf.mk3
-rw-r--r--build-aux/Makefile.once.head/10-nested.mk3
-rw-r--r--build-aux/Makefile.once.head/10-texinfo.mk6
7 files changed, 43 insertions, 21 deletions
diff --git a/build-aux/Makefile.once.head/00-var.mk b/build-aux/Makefile.once.head/00-var.mk
index 1f50f21..7c9e6ff 100644
--- a/build-aux/Makefile.once.head/00-var.mk
+++ b/build-aux/Makefile.once.head/00-var.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016 Luke Shumaker
+# Copyright (C) 2016-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -20,14 +20,17 @@ define mod.var.doc
# Outputs:
# Target : `$(outdir)/.var.%`
# Directory variable: `at.targets`
+# Directory variable: `var.`
#
# It's a well-known secret that many files generated by a Makefile vary with
# the values of particular variables, but that GNU Make can't track these
# dependencies. Well, with some cleverness, it actually can!
#
# With this module, to depend on the value of a variable, depend on
-# `$(outdir)/.var.VARNAME`.
+# `$(outdir)/.var.VARNAME`, or `$(var.)VARNAME` for short.
endef
mod.var.doc := $(value mod.var.doc)
+var. = $(patsubst ./%,%,$(outdir)/.var.)
+
.PHONY: _var.FORCE
diff --git a/build-aux/Makefile.once.head/10-dist.mk b/build-aux/Makefile.once.head/10-dist.mk
index 27b39ec..3621195 100644
--- a/build-aux/Makefile.once.head/10-dist.mk
+++ b/build-aux/Makefile.once.head/10-dist.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2015-2016 Luke Shumaker
+# Copyright (C) 2015-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -50,6 +50,12 @@ define mod.dist.doc
endef
mod.dist.doc := $(value mod.dist.doc)
+PACKAGE_TARNAME ?=
+PACKAGE ?=
+PACKAGE_NAME ?=
+PACKAGE_VERSION ?=
+VERSION ?=
+
# Developer configuration
dist.exts ?= .tar.gz
diff --git a/build-aux/Makefile.once.head/10-files.mk b/build-aux/Makefile.once.head/10-files.mk
index f6fcf30..564f9d6 100644
--- a/build-aux/Makefile.once.head/10-files.mk
+++ b/build-aux/Makefile.once.head/10-files.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2015-2016 Luke Shumaker
+# Copyright (C) 2015-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -26,15 +26,15 @@ define mod.files.doc
# - Global variable : `files.default ?= all`
# - Global variable : `files.vcsclean ?= files.vcsclean`
# - Global variable : `files.generate ?= files.generate`
-# - Directory variable : `files.src.src`
-# - Directory variable : `files.src.int`
-# - Directory variable : `files.src.cfg`
-# - Directory variable : `files.src.gen`
-# - Directory variable : `files.out.slow`
-# - Directory variable : `files.out.int`
-# - Directory variable : `files.out.cfg`
-# - Directory variable : `files.out.$(files.groups)` (well, $(addprefix...))
-# - Directory variable : `files.sys.$(files.groups)` (well, $(addprefix...))
+# - Directory variable : `files.src.src` # Sources
+# - Directory variable : `files.src.int` # Intermediates; deletable
+# - Directory variable : `files.src.cfg` # Outputs needed to run ./configure
+# - Directory variable : `files.src.gen` # Other outputs
+# - Directory variable : `files.out.slow` # Things to exclude from `make mostlyclean`
+# - Directory variable : `files.out.int` # Intermediates
+# - Directory variable : `files.out.cfg` # Outputs created by ./configure
+# - Directory variable : `files.out.$(group)` for `group` in `$(files.groups)`
+# - Directory variable : `files.sys.$(group)` for `group` in `$(files.groups)`
# Outputs:
# - Global variable : `nested.targets`
# - Global variable : `at.targets`
@@ -43,7 +43,7 @@ define mod.files.doc
# - Directory variable : `files.out`
# - Directory variable : `files.sys`
# - Creative .PHONY targets:
-# - `$(outdir)/$(files.generate))`
+# - `$(outdir)/$(files.generate)`
# - `$(outdir)/$(group)` for `group` in `$(files.groups)`
# - `$(outdir)/install`
# - `$(outdir)/install-$(group)` for `group` in `$(filter-out $(files.default),$(files.groups))`
@@ -59,6 +59,10 @@ define mod.files.doc
# Basic `*` wildcards are supported. Use `*`, not `%`; it will automatically
# substitute `*`->`%` where appropriate.
#
+# Each of the destructive targets depends on `$(target)-hook`, which
+# is defined to be a "double-colon rule" allowing you to add your own
+# code.
+#
# TODO: prose documentation
endef
mod.files.doc := $(value mod.files.doc)
@@ -76,7 +80,7 @@ nested.targets += install installdirs
nested.targets += $(foreach g,$(files.groups),$g)
nested.targets += $(foreach g,$(filter-out $(files.default),$(files.groups)),install-$g install-$gdirs)
# Standard destructive PHONY targets
-nested.targets += uninstall mostlyclean clean distclean maintainer-clean
+nested.targets += uninstall mostlyclean clean distclean maintainer-clean $(files.vcsclean)
# User configuration
@@ -85,3 +89,12 @@ DESTDIR ?=
RM ?= rm -f
RMDIR_P ?= rmdir -p --ignore-fail-on-non-empty
TRUE ?= true
+
+# Utility functions
+
+_files.XARGS = $(if $(strip $2),$1 $(strip $2))
+
+_files.maintainer-clean-warning:
+ @echo 'This command is intended for maintainers to use; it'
+ @echo 'deletes files that may need special tools to rebuild.'
+.PHONY: _files.maintainer-clean-warning
diff --git a/build-aux/Makefile.once.head/00-gitfiles.mk b/build-aux/Makefile.once.head/10-gitfiles.mk
index 8566a7f..8566a7f 100644
--- a/build-aux/Makefile.once.head/00-gitfiles.mk
+++ b/build-aux/Makefile.once.head/10-gitfiles.mk
diff --git a/build-aux/Makefile.once.head/10-gnuconf.mk b/build-aux/Makefile.once.head/10-gnuconf.mk
index e24dfa1..87baa14 100644
--- a/build-aux/Makefile.once.head/10-gnuconf.mk
+++ b/build-aux/Makefile.once.head/10-gnuconf.mk
@@ -30,6 +30,9 @@ define mod.gnuconf.doc
endef
mod.gnuconf.doc := $(value mod.gnuconf.doc)
+PACKAGE_TARNAME ?=
+PACKAGE ?=
+PACKAGE_NAME ?=
gnuconf.pkgname ?= $(firstword $(PACKAGE_TARNAME) $(PACKAGE) $(PACKAGE_NAME))
ifeq ($(gnuconf.pkgname),)
$(error Autothing module: gnuconf: gnuconf.pkgname must be set)
diff --git a/build-aux/Makefile.once.head/10-nested.mk b/build-aux/Makefile.once.head/10-nested.mk
index 4f181a9..d903d53 100644
--- a/build-aux/Makefile.once.head/10-nested.mk
+++ b/build-aux/Makefile.once.head/10-nested.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016 Luke Shumaker
+# Copyright (C) 2016-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -21,6 +21,7 @@ define mod.nested.doc
# Outputs:
# - .PHONY Targets : `$(addprefix $(outdir)/,$(nested.targets))`
# - Variable : `at.subdirs`
+# - Variable : `at.targets`
#
# The Autothing `at.subdirs` slates a subdirectory's Makefile for inclusion,
# but doesn't help with recursive targets like `all`, `install`, or `clean`,
diff --git a/build-aux/Makefile.once.head/10-texinfo.mk b/build-aux/Makefile.once.head/10-texinfo.mk
index aac2c28..d24852d 100644
--- a/build-aux/Makefile.once.head/10-texinfo.mk
+++ b/build-aux/Makefile.once.head/10-texinfo.mk
@@ -29,17 +29,13 @@ define mod.texinfo.doc
# - Directory variable : `files.out.{dvi,html,pdf,ps}`
# - Directory variable : `files.sys.{dvi,html,pdf,ps,all}`
# - .PHONY target : `$(outdir)/info`
-# - .PHONY target : `$(outdir)/install` (see below)
# - Target : `$(outdir)/%.info`
# - Target : `$(outdir)/%.dvi`
# - target : `$(outdir)/%.html`
# - target : `$(outdir)/%.pdf`
# - Target : `$(outdir)/%.ps`
#
-# The module counts on the `$(outdir)/install` target being defined by
-# `files`, but not having a rule that executes once the dependencies
-# have been taken care of; it adds a "post-install" rule to add the
-# info files to the index.
+# TODO: prose documentation
endef
mod.texinfo.doc := $(value mod.texinfo.doc)