summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.tail/00-dist.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-17 02:20:31 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-17 02:22:05 -0500
commitdd98e1c994520acc817d3dfa651ccf291827630d (patch)
tree8a5badbc1b1135cfb5357ea3aca5e82d4c5f0578 /build-aux/Makefile.once.tail/00-dist.mk
parent2d33bd2f34f011c4f025a073b50d536f6a66a4db (diff)
Backport fixes from work on parabola-hackers.git.
- core: Actually support at.Makefile; how it set the internal variable _at.MAKEFILE_LIST was broken if $(at.Makefile) != Makefile - mod: dist: * Don't try to distribute $(files.src.int) files. * Add a comment noting that the lack of the `-P` flag to `cp` is not a bug. - mod: gitfiles: * Correctly list files in $(topsrcdir). * Also enumerate files in git submodules.
Diffstat (limited to 'build-aux/Makefile.once.tail/00-dist.mk')
-rw-r--r--build-aux/Makefile.once.tail/00-dist.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/build-aux/Makefile.once.tail/00-dist.mk b/build-aux/Makefile.once.tail/00-dist.mk
index a890d9d..59a7dc3 100644
--- a/build-aux/Makefile.once.tail/00-dist.mk
+++ b/build-aux/Makefile.once.tail/00-dist.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2015-2016 Luke Shumaker
+# Copyright (C) 2015-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -13,6 +13,9 @@
# You should have received a copy of the GNU Affero General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
+# NB: intentionally resolve symlinks (tack on the -P flag to `cp` to
+# not resolve them). The GNU Coding Standards say to avoid symlinks
+# in tarballs.
_dist.copyfile = $(MKDIR_P) $(dir $2) && $(CP) -T $1 $2
_dist.addfile = $(call _dist.copyfile,$3,$2/$(call at.relto,$1,$3))
$(topoutdir)/$(dist.pkgname)-$(dist.version): $(_dist.files)