summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.tail
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-05-29 17:37:41 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-05-29 17:37:41 -0400
commit37b88c702ebe46611435f528b087d82c53dfcc77 (patch)
treee36623f4e18cfa304f35debc32ae7ba8c390466c /build-aux/Makefile.once.tail
parentcbe8694c76ea68d56073ffe3e74359a5db4d997a (diff)
rename PACKAGE->dist.name VERSION->dist.version
Diffstat (limited to 'build-aux/Makefile.once.tail')
-rw-r--r--build-aux/Makefile.once.tail/00-dist.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/build-aux/Makefile.once.tail/00-dist.mk b/build-aux/Makefile.once.tail/00-dist.mk
index ef3ecb1..ee28fac 100644
--- a/build-aux/Makefile.once.tail/00-dist.mk
+++ b/build-aux/Makefile.once.tail/00-dist.mk
@@ -15,14 +15,14 @@
_dist.copyfile = $(MKDIR_P) $(dir $2) && $(CP) -T $1 $2
_dist.addfile = $(call _dist.copyfile,$3,$2/$(call at.relto,$1,$3))
-$(topoutdir)/$(PACKAGE)-$(VERSION): $(std.src_files/$(topoutdir)) $(std.gen_files/$(topoutdir))
+$(topoutdir)/$(dist.name)-$(dist.version): $(std.src_files/$(topoutdir)) $(std.gen_files/$(topoutdir))
$(RM) -r $@
@PS4='' && set -x && \
$(MKDIR) $(@D)/tmp.$(@F).$$$$ && \
$(foreach f,$^,$(call _dist.addfile,$(topsrcdir),$(@D)/tmp.$(@F).$$$$,$f) &&) \
$(MV) $(@D)/tmp.$(@F).$$$$ $@ || $(RM) -r $(@D)/tmp.$(@F).$$$$
-$(topoutdir)/$(PACKAGE)-$(VERSION).tar: $(topoutdir)/$(PACKAGE)-$(VERSION)
+$(topoutdir)/$(dist.name)-$(dist.version).tar: $(topoutdir)/$(dist.name)-$(dist.version)
$(TAR) cf $@ -C $(<D) $(<F)
-$(topoutdir)/$(PACKAGE)-$(VERSION).tar.gz: $(topoutdir)/$(PACKAGE)-$(VERSION).tar
+$(topoutdir)/$(dist.name)-$(dist.version).tar.gz: $(topoutdir)/$(dist.name)-$(dist.version).tar
$(GZIP) $(GZIPFLAGS) < $< > $@