summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-06-15 18:43:36 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-06-15 18:43:36 -0400
commit3ae49fa9294cd1b75ea7a6f7024ccc2d02f34749 (patch)
tree51cb53e18ffa254590e78788a8c6597628b70a7d /build-aux
parent64b158fa454f67bf78d53fb8cfcff4d7718e6710 (diff)
parentd98870ac5acfe42d410383dfe7f2af18923510c4 (diff)
Merge remote-tracking branch 'autothing/mod-write-ifchanged'
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/Makefile.once.head/00-write-ifchanged.mk1
-rwxr-xr-xbuild-aux/write-ifchanged25
2 files changed, 26 insertions, 0 deletions
diff --git a/build-aux/Makefile.once.head/00-write-ifchanged.mk b/build-aux/Makefile.once.head/00-write-ifchanged.mk
new file mode 100644
index 0000000..79ef1c4
--- /dev/null
+++ b/build-aux/Makefile.once.head/00-write-ifchanged.mk
@@ -0,0 +1 @@
+WRITE_IFCHANGED = $(topsrcdir)/build-aux/write-ifchanged
diff --git a/build-aux/write-ifchanged b/build-aux/write-ifchanged
new file mode 100755
index 0000000..185ceb0
--- /dev/null
+++ b/build-aux/write-ifchanged
@@ -0,0 +1,25 @@
+#!/usr/bin/env bash
+# Copyright (C) 2015 Luke Shumaker
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+outfile=$1
+tmpfile="$(dirname "$outfile")/.tmp${outfile##*/}"
+
+cat > "$tmpfile" || exit $?
+if cmp -s "$tmpfile" "$outfile"; then
+ rm -f "$tmpfile" || :
+else
+ mv -f "$tmpfile" "$outfile"
+fi