summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-06-01 13:02:33 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-06-01 13:02:33 -0400
commit786d22b74eaac27ae4c93d35e7b7718ad7d25af6 (patch)
treeebdd0551619098e85bcd1ec8d8216ecff7c9cceb /build-aux
parent0bb5183e4e1ac300e8b7f38477a0e12d7d0d3df5 (diff)
(systemd) new autothing
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/Makefile.once.head/00-dist.mk4
-rw-r--r--build-aux/Makefile.once.head/00-gnuconf.mk2
2 files changed, 3 insertions, 3 deletions
diff --git a/build-aux/Makefile.once.head/00-dist.mk b/build-aux/Makefile.once.head/00-dist.mk
index d5bfcd3..4326cde 100644
--- a/build-aux/Makefile.once.head/00-dist.mk
+++ b/build-aux/Makefile.once.head/00-dist.mk
@@ -16,8 +16,8 @@
# Developer configuration
dist.exts ?= .tar.gz
-dist.pkgname ?= $(PACKAGE)
-dist.version ?= $(VERSION)
+dist.pkgname ?= $(firstword $(PACKAGE_TARNAME) $(PACKAGE) $(PACKAGE_NAME))
+dist.version ?= $(firstword $(PACKAGE_VERSION) $(VERSION))
ifeq ($(dist.pkgname),)
$(error dist.pkgname must be set)
diff --git a/build-aux/Makefile.once.head/00-gnuconf.mk b/build-aux/Makefile.once.head/00-gnuconf.mk
index 8e10f04..83cb110 100644
--- a/build-aux/Makefile.once.head/00-gnuconf.mk
+++ b/build-aux/Makefile.once.head/00-gnuconf.mk
@@ -16,7 +16,7 @@
# This file is based on ยง7.2 "Makefile Conventions" of the release of
# the GNU Coding Standards dated April 13, 2016.
-gnuconf.pkgname ?= $(PACKAGE)
+gnuconf.pkgname ?= $(firstword $(PACKAGE_TARNAME) $(PACKAGE) $(PACKAGE_NAME))
ifeq ($(gnuconf.pkgname),)
$(error gnuconf.pkgname must be set)
endif