summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-10-30 19:27:23 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-10-30 19:27:23 -0400
commit9384e763b00774603208b3d44977ed0e6762a09a (patch)
treefd8276bc961ccb91434bc2fee08c45cfb08a0961 /build-aux
parent95d18493a5d3399993053b94cb1fc4542699f884 (diff)
(systemd) at: mod: don't call on .doc
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/Makefile.each.tail/00-mod.mk4
-rw-r--r--build-aux/Makefile.once.head/00-gitfiles.mk1
-rw-r--r--build-aux/Makefile.once.head/00-quote.mk1
-rw-r--r--build-aux/Makefile.once.head/00-var.mk1
-rw-r--r--build-aux/Makefile.once.head/10-dist.mk1
-rw-r--r--build-aux/Makefile.once.head/10-files.mk1
-rw-r--r--build-aux/Makefile.once.head/10-gnuconf.mk1
-rw-r--r--build-aux/Makefile.once.head/10-nested.mk1
-rw-r--r--build-aux/Makefile.once.head/10-write-atomic.mk1
-rw-r--r--build-aux/Makefile.once.head/10-write-ifchanged.mk1
-rw-r--r--build-aux/Makefile.once.head/zz-mod.mk5
11 files changed, 14 insertions, 4 deletions
diff --git a/build-aux/Makefile.each.tail/00-mod.mk b/build-aux/Makefile.each.tail/00-mod.mk
index 5b77436..d6514dd 100644
--- a/build-aux/Makefile.each.tail/00-mod.mk
+++ b/build-aux/Makefile.each.tail/00-mod.mk
@@ -29,7 +29,7 @@ at.targets += $(addprefix $(outdir)/, at-variables-global at-variables-local at-
$(outdir)/at-modules:
@printf 'Autothing modules used in this project:\n'
- @printf ' - %s\n' $(foreach _mod.tmp,$(_mod.modules),$(call quote.shell,$(_mod.tmp) $(mod.$(_mod.tmp).description) $(if $(value mod.$(_mod.tmp).doc),(more))))|column -t -s $$'\t'
+ @printf ' - %s\n' $(foreach _mod.tmp,$(_mod.modules),$(call quote.shell,$(_mod.tmp) $(mod.$(_mod.tmp).description) $(if $(mod.$(_mod.tmp).doc),(more))))|column -t -s $$'\t'
$(addprefix $(outdir)/at-modules/,$(_mod.modules)): $(outdir)/at-modules/%:
@printf 'Name : %s\n' $(call quote.shell,$*)
@printf 'Description : %s\n' $(call quote.shell,$(mod.$*.description))
@@ -37,7 +37,7 @@ $(addprefix $(outdir)/at-modules/,$(_mod.modules)): $(outdir)/at-modules/%:
@echo 'Files :'
@printf ' %s\n' $(call quote.shell-each,$(call at.relto,$(topsrcdir),$(sort $(mod.$*.files) $(wildcard $(topsrcdir)/build-aux/Makefile.*/??-$*.mk))))
@echo 'Documentation :'
- @printf '%s\n' $(call quote.shell,$(value mod.$*.doc)) | sed -e 's/^# / /' -e 's/^#//'
+ @printf '%s\n' $(call quote.shell,$(mod.$*.doc)) | sed -e 's/^# / /' -e 's/^#//'
$(outdir)/at-noop:
.PHONY: $(outdir)/at-noop
diff --git a/build-aux/Makefile.once.head/00-gitfiles.mk b/build-aux/Makefile.once.head/00-gitfiles.mk
index faae91d..1214e50 100644
--- a/build-aux/Makefile.once.head/00-gitfiles.mk
+++ b/build-aux/Makefile.once.head/00-gitfiles.mk
@@ -56,6 +56,7 @@ define mod.gitfiles.doc
# or may not be safe to use the value of `$(files.src.src)` in your
# Makefile, depending on how you set `nested.subdirs`.
endef
+mod.gitfiles.doc := $(value mod.gitfiles.doc)
gitfiles.file ?= gitfiles.mk
diff --git a/build-aux/Makefile.once.head/00-quote.mk b/build-aux/Makefile.once.head/00-quote.mk
index 4c954b1..94bc943 100644
--- a/build-aux/Makefile.once.head/00-quote.mk
+++ b/build-aux/Makefile.once.head/00-quote.mk
@@ -32,6 +32,7 @@ define mod.quote.doc
# whitespace), while `quote.shell` keeps them as one string (preserving
# whitespace).
endef
+mod.quote.doc := $(value mod.quote.doc)
_quote.backslash = $(if $1,$(call _quote.backslash,$(wordlist 2,$(words $1),$1),$(subst $(firstword $1),\$(firstword $1),$2)),$2)
diff --git a/build-aux/Makefile.once.head/00-var.mk b/build-aux/Makefile.once.head/00-var.mk
index 636bbb0..1f50f21 100644
--- a/build-aux/Makefile.once.head/00-var.mk
+++ b/build-aux/Makefile.once.head/00-var.mk
@@ -28,5 +28,6 @@ define mod.var.doc
# With this module, to depend on the value of a variable, depend on
# `$(outdir)/.var.VARNAME`.
endef
+mod.var.doc := $(value mod.var.doc)
.PHONY: _var.FORCE
diff --git a/build-aux/Makefile.once.head/10-dist.mk b/build-aux/Makefile.once.head/10-dist.mk
index 8c68d04..831ca12 100644
--- a/build-aux/Makefile.once.head/10-dist.mk
+++ b/build-aux/Makefile.once.head/10-dist.mk
@@ -48,6 +48,7 @@ define mod.dist.doc
# The tarball isn't reproducible. It uses file-system ordering of
# files, and includes timestamps.
endef
+mod.dist.doc := $(value mod.dist.doc)
# Developer configuration
diff --git a/build-aux/Makefile.once.head/10-files.mk b/build-aux/Makefile.once.head/10-files.mk
index 9d27ae9..e697a88 100644
--- a/build-aux/Makefile.once.head/10-files.mk
+++ b/build-aux/Makefile.once.head/10-files.mk
@@ -54,6 +54,7 @@ define mod.files.doc
#
# TODO: prose documentation
endef
+mod.files.doc := $(value mod.files.doc)
files.groups ?= all
files.default ?= all
diff --git a/build-aux/Makefile.once.head/10-gnuconf.mk b/build-aux/Makefile.once.head/10-gnuconf.mk
index 6d641bb..a4b7696 100644
--- a/build-aux/Makefile.once.head/10-gnuconf.mk
+++ b/build-aux/Makefile.once.head/10-gnuconf.mk
@@ -28,6 +28,7 @@ define mod.gnuconf.doc
# This is based on §7.2 "Makefile Conventions" of the July 25, 2016
# release of the GNU Coding Standards.
endef
+mod.gnuconf.doc := $(value mod.gnuconf.doc)
gnuconf.pkgname ?= $(firstword $(PACKAGE_TARNAME) $(PACKAGE) $(PACKAGE_NAME))
ifeq ($(gnuconf.pkgname),)
diff --git a/build-aux/Makefile.once.head/10-nested.mk b/build-aux/Makefile.once.head/10-nested.mk
index 72e15ab..4f181a9 100644
--- a/build-aux/Makefile.once.head/10-nested.mk
+++ b/build-aux/Makefile.once.head/10-nested.mk
@@ -40,5 +40,6 @@ define mod.nested.doc
# | at.subdirs | DIST_SUBDIRS |
# | nested.subdirs | SUBDIRS |
endef
+mod.nested.doc := $(value mod.nested.doc)
nested.targets ?=
diff --git a/build-aux/Makefile.once.head/10-write-atomic.mk b/build-aux/Makefile.once.head/10-write-atomic.mk
index ce6acd8..c4aa808 100644
--- a/build-aux/Makefile.once.head/10-write-atomic.mk
+++ b/build-aux/Makefile.once.head/10-write-atomic.mk
@@ -18,5 +18,6 @@ define mod.write-atomic.doc
#
# The are only different in that one is atomic, while the other is not.
endef
+mod.write-atomic.doc := $(value mod.write-atomic.doc)
WRITE_ATOMIC ?= $(topsrcdir)/build-aux/write-atomic
diff --git a/build-aux/Makefile.once.head/10-write-ifchanged.mk b/build-aux/Makefile.once.head/10-write-ifchanged.mk
index 5abb3ce..649aab9 100644
--- a/build-aux/Makefile.once.head/10-write-ifchanged.mk
+++ b/build-aux/Makefile.once.head/10-write-ifchanged.mk
@@ -18,5 +18,6 @@ define mod.write-ifchanged.doc
# ... > $@
# ... | $(WRITE_ATOMIC) $@
endef
+mod.write-ifchanged.doc := $(value mod.write-ifchanged.doc)
WRITE_IFCHANGED ?= $(topsrcdir)/build-aux/write-ifchanged
diff --git a/build-aux/Makefile.once.head/zz-mod.mk b/build-aux/Makefile.once.head/zz-mod.mk
index 1b12a2f..95d251d 100644
--- a/build-aux/Makefile.once.head/zz-mod.mk
+++ b/build-aux/Makefile.once.head/zz-mod.mk
@@ -18,7 +18,6 @@ mod.mod.depends += quote
define mod.mod.doc
# Inputs:
# - Files : `$(topsrcdir)/build-aux/Makefile.*/??-*.mk`
-# - Global variable : `mod.*.name`
# - Global variable : `mod.*.description`
# - Global variable : `mod.*.depends`
# - Global variable : `mod.*.files`
@@ -37,6 +36,7 @@ define mod.mod.doc
#
# TODO: prose documentation
endef
+mod.mod.doc := $(value mod.mod.doc)
# The trickery that is _mod.empty/_mod.space is from §6.2 of the GNU Make
# manual, "The Two Flavors of Variables".
@@ -55,4 +55,5 @@ undefine _mod.file2mod
$(eval $(foreach _mod.tmp,$(_mod.modules),\
mod.$(_mod.tmp).description ?=$(at.nl)\
mod.$(_mod.tmp).depends ?=$(at.nl)\
- mod.$(_mod.tmp).files ?=$(at.nl)))
+ mod.$(_mod.tmp).files ?=$(at.nl)\
+ mod.$(_mod.tmp).doc ?=$(at.nl)))