summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-10-30 19:28:47 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-10-30 19:28:47 -0400
commita5986ad30296a9138c7943298759526f71a510de (patch)
tree725798b6daff82256dd6714934eda1c42fe03751 /build-aux
parent9384e763b00774603208b3d44977ed0e6762a09a (diff)
(systemd) at: files: add missing things to documentaton
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/Makefile.once.head/10-files.mk17
1 files changed, 12 insertions, 5 deletions
diff --git a/build-aux/Makefile.once.head/10-files.mk b/build-aux/Makefile.once.head/10-files.mk
index e697a88..f6fcf30 100644
--- a/build-aux/Makefile.once.head/10-files.mk
+++ b/build-aux/Makefile.once.head/10-files.mk
@@ -36,14 +36,18 @@ define mod.files.doc
# - Directory variable : `files.out.$(files.groups)` (well, $(addprefix...))
# - Directory variable : `files.sys.$(files.groups)` (well, $(addprefix...))
# Outputs:
-# - Global variable : `nested.targets`
-# - Global variable : `at.targets`
-# - Global variable : `.DEFAULT_GOAL = $(files.default)`
+# - Global variable : `nested.targets`
+# - Global variable : `at.targets`
+# - Global variable : `.DEFAULT_GOAL = $(files.default)`
+# - Directory variable : `files.src`
+# - Directory variable : `files.out`
+# - Directory variable : `files.sys`
# - Creative .PHONY targets:
# - `$(outdir)/$(files.generate))`
-# - `$(addprefix $(outdir)/,$(files.groups))`
-# - `$(outdir)/installdirs`
+# - `$(outdir)/$(group)` for `group` in `$(files.groups)`
# - `$(outdir)/install`
+# - `$(outdir)/install-$(group)` for `group` in `$(filter-out $(files.default),$(files.groups))`
+# - `$(outdir)/installdirs`
# - Destructive .PHONY targets:
# - `$(outdir)/uninstall`
# - `$(outdir)/mostlyclean`
@@ -52,6 +56,9 @@ define mod.files.doc
# - `$(outdir)/maintainer-clean`
# - `$(outdir)/$(files.vcsclean)`
#
+# Basic `*` wildcards are supported. Use `*`, not `%`; it will automatically
+# substitute `*`->`%` where appropriate.
+#
# TODO: prose documentation
endef
mod.files.doc := $(value mod.files.doc)