summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-17 02:00:48 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-17 02:05:50 -0500
commitf4b4df101e4e3449494d65100ef2bab7d0bd46dd (patch)
treeef1d04ae5318a12014ef8afe5af40f2a244d1946 /config.mk
parent1ff424c47193173b24d997293f8b0b0c4efcdd48 (diff)
Fix `make dist`.
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/config.mk b/config.mk
new file mode 100644
index 0000000..5815d64
--- /dev/null
+++ b/config.mk
@@ -0,0 +1,19 @@
+ifeq ($(origin topsrcdir),undefined)
+topoutdir := $(patsubst %/,%,$(dir $(lastword $(MAKEFILE_LIST))))
+topsrcdir := $(topoutdir)
+
+PACKAGE = parabola-hackers
+VERSION = 20170117
+
+sysusersdir=$(prefix)/lib/sysusers.d
+systemunitdir=$(prefix)/lib/systemd/system
+conf_file = $(sysconfdir)/$(PACKAGE).yml
+shadow_file = $(sysconfdir)/nshd/shadow
+NET ?=
+#NET ?= FORCE
+user = nshd
+CFLAGS += -Wall -Wextra -Werror -pedantic
+CC = gcc -std=c99
+.LIBPATTERNS = lib%.so lib%.a
+
+endif