summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--build-aux/Makefile.each.tail/00-var.mk6
-rw-r--r--build-aux/Makefile.each.tail/10-files.mk21
-rw-r--r--build-aux/Makefile.each.tail/10-nested.mk3
-rw-r--r--build-aux/Makefile.each.tail/11-texinfo.mk4
-rw-r--r--build-aux/Makefile.head.mk22
-rw-r--r--build-aux/Makefile.once.head/00-var.mk7
-rw-r--r--build-aux/Makefile.once.head/10-dist.mk8
-rw-r--r--build-aux/Makefile.once.head/10-files.mk37
-rw-r--r--build-aux/Makefile.once.head/10-gitfiles.mk (renamed from build-aux/Makefile.once.head/00-gitfiles.mk)0
-rw-r--r--build-aux/Makefile.once.head/10-gnuconf.mk3
-rw-r--r--build-aux/Makefile.once.head/10-nested.mk3
-rw-r--r--build-aux/Makefile.once.head/10-texinfo.mk6
12 files changed, 67 insertions, 53 deletions
diff --git a/build-aux/Makefile.each.tail/00-var.mk b/build-aux/Makefile.each.tail/00-var.mk
index c2fd9d7..954defb 100644
--- a/build-aux/Makefile.each.tail/00-var.mk
+++ b/build-aux/Makefile.each.tail/00-var.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016 Luke Shumaker
+# Copyright (C) 2016-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -13,10 +13,10 @@
# You should have received a copy of the GNU Affero General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-mod.var.depends += quote write-ifchanged
+mod.var.depends += files quote write-ifchanged
$(outdir)/.var.%: _var.FORCE
@printf '%s' $(call quote.shell,$($*)) | sed 's/^/#/' | $(WRITE_IFCHANGED) $@
-include $(wildcard $(outdir)/.var.*)
-at.targets += $(addprefix $(outdir)/,.var.%)
+files.out.int += .var.*
diff --git a/build-aux/Makefile.each.tail/10-files.mk b/build-aux/Makefile.each.tail/10-files.mk
index 3bb3bc2..787a3bd 100644
--- a/build-aux/Makefile.each.tail/10-files.mk
+++ b/build-aux/Makefile.each.tail/10-files.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2015-2016 Luke Shumaker
+# Copyright (C) 2015-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -41,17 +41,12 @@ _files.uninstall = $(_files.sys)
_files.mostlyclean = $(filter-out $(_files.out.slow) $(_files.out.cfg),$(_files.out))
_files.clean = $(filter-out $(_files.out.cfg),$(_files.out))
_files.distclean = $(_files.out)
-$(addprefix $(outdir)/,uninstall mostlyclean clean distclean): %: %-hook
- $(RM) -- $(sort $(filter-out %/,$(_files.$(@F))))
- $(RM) -r -- $(sort $(filter %/,$(_files.$(@F))))
- $(RMDIR_P) -- $(sort $(dir $(_files.$(@F))))
-_files.maintainer-clean = $(filter-out $(_files.src.cfg) $(_files.src.src),$(_files.src))
-_files.$(files.vcsclean) = $(filter-out $(_files.src.src),$(_files.src))
-$(addprefix $(outdir)/,maintainer-clean $(files.vcsclean)): $(outdir)/%: $(outdir)/distclean $(outdir)/%-hook
- @echo 'This command is intended for maintainers to use; it'
- @echo 'deletes files that may need special tools to rebuild.'
- $(RM) -- $(sort $(filter-out %/,$(_files.$(@F))))
- $(RM) -r -- $(sort $(filter %/,$(_files.$(@F))))
- $(RMDIR_P) -- $(sort $(dir $(_files.$(@F))))
+_files.maintainer-clean = $(_files.distclean) $(filter-out $(_files.src.cfg) $(_files.src.src),$(_files.src))
+_files.$(files.vcsclean) = $(_files.distclean) $(filter-out $(_files.src.src),$(_files.src))
+$(addprefix $(outdir)/,uninstall mostlyclean clean distclean maintainer-clean $(files.vcsclean)): %: %-hook
+ $(call _files.XARGS,$(RM) --, $(sort $(wildcard $(filter-out %/,$(_files.$(@F))))) )
+ $(call _files.XARGS,$(RM) -r --, $(sort $(wildcard $(filter %/,$(_files.$(@F))))) )
+ $(call _files.XARGS,$(RMDIR_P) --,$(filter-out ./,$(sort $(wildcard $(dir $(_files.$(@F)))))))
+$(addprefix $(outdir)/,maintainer-clean $(files.vcsclean)): _files.maintainer-clean-warning
$(foreach t,uninstall mostlyclean clean distclean maintainer-clean $(files.vcsclean), $(outdir)/$t-hook)::
.PHONY: $(foreach t,uninstall mostlyclean clean distclean maintainer-clean $(files.vcsclean), $(outdir)/$t-hook)
diff --git a/build-aux/Makefile.each.tail/10-nested.mk b/build-aux/Makefile.each.tail/10-nested.mk
index 5e5a40b..667ec6f 100644
--- a/build-aux/Makefile.each.tail/10-nested.mk
+++ b/build-aux/Makefile.each.tail/10-nested.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016 Luke Shumaker
+# Copyright (C) 2016-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -18,3 +18,4 @@ $(eval $(foreach _tmp.nested,$(nested.targets),\
.PHONY: $(addprefix $(outdir)/,$(nested.targets))
at.subdirs += $(nested.subdirs)
+at.targets += $(addprefix $(outdir)/,$(nested.targets))
diff --git a/build-aux/Makefile.each.tail/11-texinfo.mk b/build-aux/Makefile.each.tail/11-texinfo.mk
index 9491820..1ee5843 100644
--- a/build-aux/Makefile.each.tail/11-texinfo.mk
+++ b/build-aux/Makefile.each.tail/11-texinfo.mk
@@ -26,10 +26,6 @@ files.sys.html += $(foreach f,$(texinfo.docs), $(htmldir)/$f.html )
files.sys.pdf += $(foreach f,$(texinfo.docs), $(pdfdir)/$f.pdf )
files.sys.ps += $(foreach f,$(texinfo.docs), $(psdir)/$f.ps )
-$(outdir)/install:
- $(POST_INSTALL)
- $(foreach f,$(texinfo.docs),$(INSTALL_INFO) $(DESTDIR)$(infodir)/$f.info $(DESTDIR)$(infodir)/dir$(at.nl))
-
$(outdir)/%.info: $(srcdir)/%.texi; $(MAKEINFO) -o $(@D) $<
$(outdir)/%.info: $(outdir)/%.texi; $(MAKEINFO) -o $(@D) $<
$(outdir)/%.dvi : $(srcdir)/%.texi; $(TEXI2DVI) -o $(@D) $<
diff --git a/build-aux/Makefile.head.mk b/build-aux/Makefile.head.mk
index f4eb51d..6ac3d49 100644
--- a/build-aux/Makefile.head.mk
+++ b/build-aux/Makefile.head.mk
@@ -32,17 +32,19 @@ _at.relbase = $(strip \
_at.relto = $(strip \
$(if $(call _at.is_subdir,$1,$2), \
$(patsubst %/.,%,$(patsubst $(abspath $1)/%,%,$(abspath $2)/.)), \
- ../$(call _at.relto,$(dir $1),$2)))
+ ../$(call _at.relto,$(dir $(abspath $1)),$2)))
# These 3 functions only take one operand; we define public multi-operand
# versions below.
-_at.path = $(strip \
- $(if $(call _at.is_subdir,$(topoutdir),$1), \
- $(patsubst %/.,%,$(topoutdir)/$(call _at.relto,.,$1)), \
- $(if $(call _at.is_subdir,$(topsrcdir),$1), \
- $(patsubst %/.,%,$(topsrcdir)/$(call _at.relto,$(topsrcdir),$1)), \
- $(abspath $1))))
-_at.out2src = $(call _at.path,$(if $(call _at.is_subdir,$(topoutdir),$1),$(topsrcdir)/$(call _at.path,$1),$1))
+_at.path = $(strip $(or \
+ $(if $(call _at.is_subdir, . ,$1), $(call _at.relto, . ,$1) ), \
+ $(if $(call _at.is_subdir,$(topoutdir),$1),$(patsubst %/.,%,$(topoutdir)/$(call _at.relto,$(topoutdir),$1))), \
+ $(if $(call _at.is_subdir,$(topsrcdir),$1),$(patsubst %/.,%,$(topsrcdir)/$(call _at.relto,$(topsrcdir),$1))), \
+ $(abspath $1)))
+_at.out2src = $(call _at.path,$(strip \
+ $(if $(call _at.is_subdir,$(topoutdir),$1), \
+ $(topsrcdir)/$(call _at.relto,$(topoutdir),$1), \
+ $1)))
_at.addprefix = $(call _at.path,$(if $(filter-out /%,$2),$1/$2,$2))
_at.rest = $(wordlist 2,$(words $1),$1)
@@ -103,9 +105,7 @@ ifeq ($(call _at.is_subdir,$(topoutdir),$(outdir)),)
$(error Autothing: not a subdirectory of topoutdir=$(topoutdir): $(outdir))
endif
-# Don't use at.out2src because we *know* that $(outdir) is inside $(topoutdir),
-# and has already had $(_at.path) called on it.
-srcdir := $(call _at.path,$(topsrcdir)/$(outdir))
+srcdir := $(call _at.out2src,$(outdir))
ifeq ($(call _at.is_subdir,$(topsrcdir),$(srcdir)),)
$(error Autothing: not a subdirectory of topsrcdir=$(topsrcdir): $(srcdir))
endif
diff --git a/build-aux/Makefile.once.head/00-var.mk b/build-aux/Makefile.once.head/00-var.mk
index 1f50f21..7c9e6ff 100644
--- a/build-aux/Makefile.once.head/00-var.mk
+++ b/build-aux/Makefile.once.head/00-var.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016 Luke Shumaker
+# Copyright (C) 2016-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -20,14 +20,17 @@ define mod.var.doc
# Outputs:
# Target : `$(outdir)/.var.%`
# Directory variable: `at.targets`
+# Directory variable: `var.`
#
# It's a well-known secret that many files generated by a Makefile vary with
# the values of particular variables, but that GNU Make can't track these
# dependencies. Well, with some cleverness, it actually can!
#
# With this module, to depend on the value of a variable, depend on
-# `$(outdir)/.var.VARNAME`.
+# `$(outdir)/.var.VARNAME`, or `$(var.)VARNAME` for short.
endef
mod.var.doc := $(value mod.var.doc)
+var. = $(patsubst ./%,%,$(outdir)/.var.)
+
.PHONY: _var.FORCE
diff --git a/build-aux/Makefile.once.head/10-dist.mk b/build-aux/Makefile.once.head/10-dist.mk
index 27b39ec..3621195 100644
--- a/build-aux/Makefile.once.head/10-dist.mk
+++ b/build-aux/Makefile.once.head/10-dist.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2015-2016 Luke Shumaker
+# Copyright (C) 2015-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -50,6 +50,12 @@ define mod.dist.doc
endef
mod.dist.doc := $(value mod.dist.doc)
+PACKAGE_TARNAME ?=
+PACKAGE ?=
+PACKAGE_NAME ?=
+PACKAGE_VERSION ?=
+VERSION ?=
+
# Developer configuration
dist.exts ?= .tar.gz
diff --git a/build-aux/Makefile.once.head/10-files.mk b/build-aux/Makefile.once.head/10-files.mk
index f6fcf30..564f9d6 100644
--- a/build-aux/Makefile.once.head/10-files.mk
+++ b/build-aux/Makefile.once.head/10-files.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2015-2016 Luke Shumaker
+# Copyright (C) 2015-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -26,15 +26,15 @@ define mod.files.doc
# - Global variable : `files.default ?= all`
# - Global variable : `files.vcsclean ?= files.vcsclean`
# - Global variable : `files.generate ?= files.generate`
-# - Directory variable : `files.src.src`
-# - Directory variable : `files.src.int`
-# - Directory variable : `files.src.cfg`
-# - Directory variable : `files.src.gen`
-# - Directory variable : `files.out.slow`
-# - Directory variable : `files.out.int`
-# - Directory variable : `files.out.cfg`
-# - Directory variable : `files.out.$(files.groups)` (well, $(addprefix...))
-# - Directory variable : `files.sys.$(files.groups)` (well, $(addprefix...))
+# - Directory variable : `files.src.src` # Sources
+# - Directory variable : `files.src.int` # Intermediates; deletable
+# - Directory variable : `files.src.cfg` # Outputs needed to run ./configure
+# - Directory variable : `files.src.gen` # Other outputs
+# - Directory variable : `files.out.slow` # Things to exclude from `make mostlyclean`
+# - Directory variable : `files.out.int` # Intermediates
+# - Directory variable : `files.out.cfg` # Outputs created by ./configure
+# - Directory variable : `files.out.$(group)` for `group` in `$(files.groups)`
+# - Directory variable : `files.sys.$(group)` for `group` in `$(files.groups)`
# Outputs:
# - Global variable : `nested.targets`
# - Global variable : `at.targets`
@@ -43,7 +43,7 @@ define mod.files.doc
# - Directory variable : `files.out`
# - Directory variable : `files.sys`
# - Creative .PHONY targets:
-# - `$(outdir)/$(files.generate))`
+# - `$(outdir)/$(files.generate)`
# - `$(outdir)/$(group)` for `group` in `$(files.groups)`
# - `$(outdir)/install`
# - `$(outdir)/install-$(group)` for `group` in `$(filter-out $(files.default),$(files.groups))`
@@ -59,6 +59,10 @@ define mod.files.doc
# Basic `*` wildcards are supported. Use `*`, not `%`; it will automatically
# substitute `*`->`%` where appropriate.
#
+# Each of the destructive targets depends on `$(target)-hook`, which
+# is defined to be a "double-colon rule" allowing you to add your own
+# code.
+#
# TODO: prose documentation
endef
mod.files.doc := $(value mod.files.doc)
@@ -76,7 +80,7 @@ nested.targets += install installdirs
nested.targets += $(foreach g,$(files.groups),$g)
nested.targets += $(foreach g,$(filter-out $(files.default),$(files.groups)),install-$g install-$gdirs)
# Standard destructive PHONY targets
-nested.targets += uninstall mostlyclean clean distclean maintainer-clean
+nested.targets += uninstall mostlyclean clean distclean maintainer-clean $(files.vcsclean)
# User configuration
@@ -85,3 +89,12 @@ DESTDIR ?=
RM ?= rm -f
RMDIR_P ?= rmdir -p --ignore-fail-on-non-empty
TRUE ?= true
+
+# Utility functions
+
+_files.XARGS = $(if $(strip $2),$1 $(strip $2))
+
+_files.maintainer-clean-warning:
+ @echo 'This command is intended for maintainers to use; it'
+ @echo 'deletes files that may need special tools to rebuild.'
+.PHONY: _files.maintainer-clean-warning
diff --git a/build-aux/Makefile.once.head/00-gitfiles.mk b/build-aux/Makefile.once.head/10-gitfiles.mk
index 8566a7f..8566a7f 100644
--- a/build-aux/Makefile.once.head/00-gitfiles.mk
+++ b/build-aux/Makefile.once.head/10-gitfiles.mk
diff --git a/build-aux/Makefile.once.head/10-gnuconf.mk b/build-aux/Makefile.once.head/10-gnuconf.mk
index e24dfa1..87baa14 100644
--- a/build-aux/Makefile.once.head/10-gnuconf.mk
+++ b/build-aux/Makefile.once.head/10-gnuconf.mk
@@ -30,6 +30,9 @@ define mod.gnuconf.doc
endef
mod.gnuconf.doc := $(value mod.gnuconf.doc)
+PACKAGE_TARNAME ?=
+PACKAGE ?=
+PACKAGE_NAME ?=
gnuconf.pkgname ?= $(firstword $(PACKAGE_TARNAME) $(PACKAGE) $(PACKAGE_NAME))
ifeq ($(gnuconf.pkgname),)
$(error Autothing module: gnuconf: gnuconf.pkgname must be set)
diff --git a/build-aux/Makefile.once.head/10-nested.mk b/build-aux/Makefile.once.head/10-nested.mk
index 4f181a9..d903d53 100644
--- a/build-aux/Makefile.once.head/10-nested.mk
+++ b/build-aux/Makefile.once.head/10-nested.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016 Luke Shumaker
+# Copyright (C) 2016-2017 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -21,6 +21,7 @@ define mod.nested.doc
# Outputs:
# - .PHONY Targets : `$(addprefix $(outdir)/,$(nested.targets))`
# - Variable : `at.subdirs`
+# - Variable : `at.targets`
#
# The Autothing `at.subdirs` slates a subdirectory's Makefile for inclusion,
# but doesn't help with recursive targets like `all`, `install`, or `clean`,
diff --git a/build-aux/Makefile.once.head/10-texinfo.mk b/build-aux/Makefile.once.head/10-texinfo.mk
index aac2c28..d24852d 100644
--- a/build-aux/Makefile.once.head/10-texinfo.mk
+++ b/build-aux/Makefile.once.head/10-texinfo.mk
@@ -29,17 +29,13 @@ define mod.texinfo.doc
# - Directory variable : `files.out.{dvi,html,pdf,ps}`
# - Directory variable : `files.sys.{dvi,html,pdf,ps,all}`
# - .PHONY target : `$(outdir)/info`
-# - .PHONY target : `$(outdir)/install` (see below)
# - Target : `$(outdir)/%.info`
# - Target : `$(outdir)/%.dvi`
# - target : `$(outdir)/%.html`
# - target : `$(outdir)/%.pdf`
# - Target : `$(outdir)/%.ps`
#
-# The module counts on the `$(outdir)/install` target being defined by
-# `files`, but not having a rule that executes once the dependencies
-# have been taken care of; it adds a "post-install" rule to add the
-# info files to the index.
+# TODO: prose documentation
endef
mod.texinfo.doc := $(value mod.texinfo.doc)