summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 43af046..79b21d6 100644
--- a/Makefile
+++ b/Makefile
@@ -67,7 +67,7 @@ $(outdir)/.gopath/src: $(golang.var)
mkdir $(@D)
ln -sr $(topsrcdir)/go $@
touch $@
-$(outdir)/.gopath/bin/cmd-nshd: $(call golang.src,$(outdir)/.gopath) $(_gen) $(_out)
+$(outdir)/.gopath/bin/cmd-nshd: $(patsubst $(outdir)/.gopath/src/%,go/%,$(call golang.src,$(outdir)/.gopath)) $(_gen) $(_out)
$(call golang.install,$(topoutdir)/.gopath,cmd-nshd)
$(outdir)/%.o: $(srcdir)/%.c $(var)CC $(var)CPPFLAGS $(var)CFLAGS