summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..accda79
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,17 @@
+PREFIX=/srv/git
+USER=git
+SHELL=/usr/bin/git-shell
+HACKERS=$(PWD)
+
+# Create the user
+user:
+ useradd -d $(PREFIX) -m -r -s $(SHELL) -U
+
+install: user
+ pushd $(PREFIX)
+ git clone --bare $(HACKERS) hackers.git
+ git clone hackers.git .ssh
+ chmod 700 .ssh
+ chmod 600 .ssh/authorized_keys
+ ln -s $(PREFIX)/.ssh/git-hooks/* hackers.git/hooks/
+ ln -s $(PREFIX)/.ssh/git-shell-commands .