summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile3
-rw-r--r--build-aux/Makefile.each.tail/00-dist.mk2
2 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index a07239d..2453dbb 100644
--- a/Makefile
+++ b/Makefile
@@ -57,9 +57,10 @@ $(srcdir)/LICENSE.wtfpl-2.txt: $(NET)
curl http://www.wtfpl.net/txt/copying/ > $@
files.generate: go-generate
-go-generate: .gopath
+go-generate: .gopath/src
+GOPATH=$(abspath $(outdir)/.gopath) go generate git.lukeshu.com/...
.PHONY: go-generate
+files.src.int += .gopath/ .gopath/*
at.targets += go-generate
#
diff --git a/build-aux/Makefile.each.tail/00-dist.mk b/build-aux/Makefile.each.tail/00-dist.mk
index bc2a3d5..b023e80 100644
--- a/build-aux/Makefile.each.tail/00-dist.mk
+++ b/build-aux/Makefile.each.tail/00-dist.mk
@@ -1 +1 @@
-_dist.files := $(strip $(_dist.files) $(call at.addprefix,$(srcdir),$(files.src)))
+_dist.files := $(strip $(_dist.files) $(call at.addprefix,$(srcdir),$(filter-out $(files.src.int),$(files.src))))