summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--LICENSE.txt9
-rw-r--r--README.md7
-rw-r--r--build-aux/Makefile.once.head/20-golang.mk13
-rw-r--r--build-aux/Makefile.once.head/20-var.mk13
-rw-r--r--scripts/common.rb.in14
-rwxr-xr-xscripts/meta-cat14
-rwxr-xr-xscripts/meta-check14
-rwxr-xr-xscripts/meta-normalize-stdio14
-rwxr-xr-xscripts/pacman-make-keyring14
-rwxr-xr-xscripts/pgp-list-keyids14
-rwxr-xr-xscripts/postfix-generate-virtual-map14
-rwxr-xr-xscripts/ssh-list-authorized-keys14
-rwxr-xr-xscripts/uid-map14
13 files changed, 165 insertions, 3 deletions
diff --git a/LICENSE.txt b/LICENSE.txt
index 6031cd7..9e6ff48 100644
--- a/LICENSE.txt
+++ b/LICENSE.txt
@@ -11,9 +11,12 @@ The software in this repository is under a number of licenses:
src/lukeshu.com/git/go/libnslcd.git/ LGPL v2.1+
src/lukeshu.com/git/go/libsystemd.git/ Apache v2.0
-The general notion is that the core application is GPL (v2+), while
-supporting libraries that might be useful outside of this specific
-application are LGPL (v2.1+), with the exceptions:
+ build-aux/ AGPL v3+
+
+The general notion is that the build system is AGPL (v3+), the core
+application is GPL (v2+), while supporting libraries that might be
+useful outside of this specific application are LGPL (v2.1+), with the
+exceptions:
- The systemd package is Apache licensed because of code taken from
CoreOS and Docker.
- The dl package is GPL v2+ licensed because of wording in comments
diff --git a/README.md b/README.md
index 8023be7..ef3371b 100644
--- a/README.md
+++ b/README.md
@@ -91,3 +91,10 @@ Add `ldap` to the `passwd`, `group`, and `shadow` fields in
Then enable and start `nshd.socket`:
systemctl enable --now nshd.socket
+
+----
+Copyright (C) 2014, 2016 Luke Shumaker
+
+This documentation file is placed into the public domain. If that is
+not possible in your legal system, I grant you permission to use it in
+absolutely every way that I can legally grant to you.
diff --git a/build-aux/Makefile.once.head/20-golang.mk b/build-aux/Makefile.once.head/20-golang.mk
index ed3056c..8d10a47 100644
--- a/build-aux/Makefile.once.head/20-golang.mk
+++ b/build-aux/Makefile.once.head/20-golang.mk
@@ -1,4 +1,17 @@
# Copyright 2015-2016 Luke Shumaker
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
golang.Q ?= @
golang.FLAGS ?=
diff --git a/build-aux/Makefile.once.head/20-var.mk b/build-aux/Makefile.once.head/20-var.mk
index 5f97ef7..b1de987 100644
--- a/build-aux/Makefile.once.head/20-var.mk
+++ b/build-aux/Makefile.once.head/20-var.mk
@@ -1,4 +1,17 @@
# Copyright 2015-2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
var = $(patsubst ./%,%,$(topoutdir)/.var.)
diff --git a/scripts/common.rb.in b/scripts/common.rb.in
index 6e02073..d81fa0c 100644
--- a/scripts/common.rb.in
+++ b/scripts/common.rb.in
@@ -1,4 +1,18 @@
# Copyright 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+#
+# This is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This software is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this manual; if not, see
+# <http://www.gnu.org/licenses/>.
require 'yaml'
diff --git a/scripts/meta-cat b/scripts/meta-cat
index 8fe4111..5e7097e 100755
--- a/scripts/meta-cat
+++ b/scripts/meta-cat
@@ -2,6 +2,20 @@
# Usage: meta-cat
# Copyright 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+#
+# This is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This software is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this manual; if not, see
+# <http://www.gnu.org/licenses/>.
load "#{File.dirname(__FILE__)}/common.rb"
diff --git a/scripts/meta-check b/scripts/meta-check
index 5862c2e..4add9d3 100755
--- a/scripts/meta-check
+++ b/scripts/meta-check
@@ -1,6 +1,20 @@
#!/bin/bash
# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
# Copyright 2015 Márcio Alexandre Silva Delgado <coadde@parabola.nu>.
+#
+# This is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This software is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this manual; if not, see
+# <http://www.gnu.org/licenses/>.
. libremessages
diff --git a/scripts/meta-normalize-stdio b/scripts/meta-normalize-stdio
index 42cbe6e..58dd531 100755
--- a/scripts/meta-normalize-stdio
+++ b/scripts/meta-normalize-stdio
@@ -3,6 +3,20 @@
# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
# Copyright 2015 Márcio Alexandre Silva Delgado <coadde@parabola.nu>.
+#
+# This is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This software is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this manual; if not, see
+# <http://www.gnu.org/licenses/>.
# First we define a bunch of code-generators, then at the end is a
# very neat and readable definition of the format of the YAML files.
diff --git a/scripts/pacman-make-keyring b/scripts/pacman-make-keyring
index 4fa2a0d..702ea69 100755
--- a/scripts/pacman-make-keyring
+++ b/scripts/pacman-make-keyring
@@ -2,6 +2,20 @@
# Usage: pacman-make-keyring V=$(date -u +%Y%m%d)
# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+#
+# This is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This software is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this manual; if not, see
+# <http://www.gnu.org/licenses/>.
ifeq ($(origin V),undefined)
$(info Usage: pacman-make-keyring V=$$(date -u +%Y%m%d))
diff --git a/scripts/pgp-list-keyids b/scripts/pgp-list-keyids
index 822c89c..749cb7b 100755
--- a/scripts/pgp-list-keyids
+++ b/scripts/pgp-list-keyids
@@ -2,6 +2,20 @@
# Usage: pgp-list-keyids
# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+#
+# This is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This software is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this manual; if not, see
+# <http://www.gnu.org/licenses/>.
load "#{File.dirname(__FILE__)}/common.rb"
diff --git a/scripts/postfix-generate-virtual-map b/scripts/postfix-generate-virtual-map
index 2620060..f2fb8ec 100755
--- a/scripts/postfix-generate-virtual-map
+++ b/scripts/postfix-generate-virtual-map
@@ -2,6 +2,20 @@
# Usage: postfix-show-virtual-map > ${file} && postmap hash:${file}
# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+#
+# This is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This software is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this manual; if not, see
+# <http://www.gnu.org/licenses/>.
load "#{File.dirname(__FILE__)}/common.rb"
diff --git a/scripts/ssh-list-authorized-keys b/scripts/ssh-list-authorized-keys
index 7bda72b..5364ac2 100755
--- a/scripts/ssh-list-authorized-keys
+++ b/scripts/ssh-list-authorized-keys
@@ -2,6 +2,20 @@
# Usage: ssh-list-authorized-keys [username]
# Copyright 2014, 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+#
+# This is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This software is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this manual; if not, see
+# <http://www.gnu.org/licenses/>.
load "#{File.dirname(__FILE__)}/common.rb"
diff --git a/scripts/uid-map b/scripts/uid-map
index 01665bc..e759c30 100755
--- a/scripts/uid-map
+++ b/scripts/uid-map
@@ -2,6 +2,20 @@
# Usage: uid-map
# Copyright 2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+#
+# This is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This software is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this manual; if not, see
+# <http://www.gnu.org/licenses/>.
load "#{File.dirname(__FILE__)}/common.rb"