summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f408ba9..b084c00 100644
--- a/Makefile
+++ b/Makefile
@@ -41,6 +41,9 @@ GOPATH = $(abspath $(topoutdir)/go)
go_variables := $(shell go env|cut -d= -f1)
$(foreach v,$(go_variables),$(if $(filter GO% CGO%,$v),$(eval $v ?=),$(eval go_$v ?=)))
go_env = $(foreach v,$(go_variables),$(if $(go_$v),$v='$(go_$v)',$(if $($v),$v='$($v)')))
+# FIXME: fails to build on parabola since ~2019, without this change:
+# GO111MODULE=auto allows mixing module-type and non-module-type go packages
+go_env += GO111MODULE=auto
#
# Generate (pre-tarball)