summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a6b680f..dc0bc13 100644
--- a/Makefile
+++ b/Makefile
@@ -19,6 +19,11 @@
# License along with this manual; if not, see
# <http://www.gnu.org/licenses/>.
+prefix=/usr
+bindir=$(libexecdir)/$(PACKAGE)
+libexecdir=$(libdir)
+sysconfdir=/etc
+
PACKAGE = parabola-hackers
sysusersdir=$(prefix)/lib/sysusers.d
systemunitdir=$(prefix)/lib/systemd/system
@@ -35,7 +40,7 @@ topoutdir := $(topsrcdir)
include $(topsrcdir)/build-aux/Makefile.head.mk
CGO_CPPFLAGS = $(CPPFLAGS) -U_FORTIFY_SOURCE
-CGO_CFLAGS = $(CFLAGS) -Wno-unused-parameter
+CGO_CFLAGS = $(CFLAGS) -O0 -Wno-unused-parameter
CGO_ENABLED = 1
at.subdirs += src/lukeshu.com/git/go/libnslcd.git/proto