summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f3b7afe..5031c03 100644
--- a/Makefile
+++ b/Makefile
@@ -30,6 +30,11 @@ check:
exit 1 ;\
fi
+# Add the hackers repo to the local clone
+install-local:
+ git remote add git git:hackers.git
+ cat ssh_config >>$(HOME)/.ssh/config
+
# Create the hackers.git bare repo and clone as .ssh
# Then create needed symlinks and add hooks to hackers.git
install: check
@@ -41,4 +46,4 @@ install: check
chmod 600 .ssh/authorized_keys && \
ln -s $(PREFIX)/.ssh/git-hooks/* hackers.git/hooks/ && \
ln -s $(PREFIX)/.ssh/git-shell-commands && \
- chown -R $(USER):$(USER) $(PREFIX)
+ chown -R $(USER):$(USER) $(PREFIX)