summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1c5d097..41ea59f 100644
--- a/Makefile
+++ b/Makefile
@@ -34,6 +34,7 @@ uninstall:
.PHONY: uninstall
$(foreach d,$(deps),$(eval src/$d: NET; GOPATH='$(GOPATH)' go get -d -u $d))
+.PHONY: NET
bin/nshd: $(download) $(generate) $(shell find src -name .git -prune -o -print)
GOPATH='$(GOPATH)' go install nshd
@@ -45,5 +46,5 @@ $(DESTDIR)$(systemddir)/system/%.socket: %.socket
$(DESTDIR)$(systemddir)/system/%.service: %.service
install -Dm644 $< $@
-.PHONY: all generate build clean install uninstall download NET
.SECONDARY:
+.DELETE_ON_ERROR: