summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f408ba9..5a01ff7 100644
--- a/Makefile
+++ b/Makefile
@@ -93,6 +93,7 @@ go_race_os_arch = $(shell go help build | sed -n '/^\s*-race/,/^\s*-/p'| grep -o
go_test_flags = $(if $(filter $(go_os_arch),$(go_race_os_arch)),-race)
$(outdir)/check:
$(go_env) go test $(go_test_flags) $$($(go_env) go list -f '{{.ImportPath}}{{"\n"}}{{join .Deps "\n"}}' $(bins_go) | sort -u | grep -e ^nshd -e '\.[^/]*/')
+ tests/test-ssh-list-authorized-keys
.PHONY: $(outdir)/check
at.targets += $(outdir)/check
@@ -118,6 +119,12 @@ $(DESTDIR)$(sysusersdir)/%.conf: $(outdir)/%.sysusers
$(DESTDIR)$(bindir)/common.rb: $(srcdir)/bin/common.rb
$(NORMAL_INSTALL)
install -TDm644 $< $@
+$(DESTDIR)$(bindir)/tests/test-%.yml: $(srcdir)/tests/test-%
+ $(NORMAL_INSTALL)
+ install -TDm755 $< $@
+$(DESTDIR)$(bindir)/tests/%.yml: $(srcdir)/tests/%.yml
+ $(NORMAL_INSTALL)
+ install -TDm644 $< $@
$(DESTDIR)$(conf_file): $(srcdir)/parabola-hackers.yml
$(NORMAL_INSTALL)
install -TDm644 $< $@