summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 41ea59f..0ccd82e 100644
--- a/Makefile
+++ b/Makefile
@@ -6,10 +6,11 @@ systemddir = $(libdir)/systemd
GOPATH := $(realpath $(dir $(lastword $(MAKEFILE_LIST))))
deps = golang.org/x/exp/inotify gopkg.in/yaml.v2
+subdirs = src/nslcd_proto
all: build
-include src/nslcd_proto/Makefile
+include $(addsuffix /Makefile,$(subdirs))
secondary +=
download += $(addprefix src/,$(deps))
@@ -25,7 +26,7 @@ install: $(install)
clean:
rm -rf -- pkg bin src/*.*/
- rm -f -- $(generate) $(build) $(decondary)
+ rm -f -- $(generate) $(build) $(secondary)
.PHONY: clean
uninstall: