summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.head.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.head.mk')
-rw-r--r--build-aux/Makefile.head.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/build-aux/Makefile.head.mk b/build-aux/Makefile.head.mk
index e5ef379..c680f41 100644
--- a/build-aux/Makefile.head.mk
+++ b/build-aux/Makefile.head.mk
@@ -16,6 +16,13 @@
# This bit only gets evaluated once, at the very beginning
ifeq ($(_at.NO_ONCE),)
+ifeq ($(topsrcdir),)
+$(error topsrcdir must be set before including Makefile.head.mk)
+endif
+ifeq ($(topoutdir),)
+$(error topoutdir must be set before including Makefile.head.mk)
+endif
+
_at.noslash = $(patsubst %/.,%,$(patsubst %/,%,$1))
# These are all $(call _at.func,parent,child)
#_at.relto = $(if $2,$(shell realpath -sm --relative-to='$1' $2))