summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/00-dist.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.once.head/00-dist.mk')
-rw-r--r--build-aux/Makefile.once.head/00-dist.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/build-aux/Makefile.once.head/00-dist.mk b/build-aux/Makefile.once.head/00-dist.mk
index d5bfcd3..4326cde 100644
--- a/build-aux/Makefile.once.head/00-dist.mk
+++ b/build-aux/Makefile.once.head/00-dist.mk
@@ -16,8 +16,8 @@
# Developer configuration
dist.exts ?= .tar.gz
-dist.pkgname ?= $(PACKAGE)
-dist.version ?= $(VERSION)
+dist.pkgname ?= $(firstword $(PACKAGE_TARNAME) $(PACKAGE) $(PACKAGE_NAME))
+dist.version ?= $(firstword $(PACKAGE_VERSION) $(VERSION))
ifeq ($(dist.pkgname),)
$(error dist.pkgname must be set)