summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/10-std.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.once.head/10-std.mk')
-rw-r--r--build-aux/Makefile.once.head/10-std.mk20
1 files changed, 11 insertions, 9 deletions
diff --git a/build-aux/Makefile.once.head/10-std.mk b/build-aux/Makefile.once.head/10-std.mk
index dec850c..b3d7c4a 100644
--- a/build-aux/Makefile.once.head/10-std.mk
+++ b/build-aux/Makefile.once.head/10-std.mk
@@ -17,15 +17,17 @@
all: build
.PHONY: all
+DESTDIR ?=
+
# Standard creative PHONY targets
-$(_am)phony += build install installdirs
+at.phony += build install installdirs
# Standard destructive PHONY targets
-$(_am)phony += uninstall mostlyclean clean distclean maintainer-clean
+at.phony += uninstall mostlyclean clean distclean maintainer-clean
-$(_am)dirlocal += $(_am)src_files
-$(_am)dirlocal += $(_am)gen_files
-$(_am)dirlocal += $(_am)cfg_files
-$(_am)dirlocal += $(_am)out_files
-$(_am)dirlocal += $(_am)sys_files
-$(_am)dirlocal += $(_am)clean_files
-$(_am)dirlocal += $(_am)slow_files
+at.dirlocal += std.src_files
+at.dirlocal += std.gen_files
+at.dirlocal += std.cfg_files
+at.dirlocal += std.out_files
+at.dirlocal += std.sys_files
+at.dirlocal += std.clean_files
+at.dirlocal += std.slow_files