summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/10-std.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.once.head/10-std.mk')
-rw-r--r--build-aux/Makefile.once.head/10-std.mk12
1 files changed, 9 insertions, 3 deletions
diff --git a/build-aux/Makefile.once.head/10-std.mk b/build-aux/Makefile.once.head/10-std.mk
index b3d7c4a..3e058ec 100644
--- a/build-aux/Makefile.once.head/10-std.mk
+++ b/build-aux/Makefile.once.head/10-std.mk
@@ -15,9 +15,7 @@
# Declare the default target
all: build
-.PHONY: all
-
-DESTDIR ?=
+.PHONY: all noop
# Standard creative PHONY targets
at.phony += build install installdirs
@@ -31,3 +29,11 @@ at.dirlocal += std.out_files
at.dirlocal += std.sys_files
at.dirlocal += std.clean_files
at.dirlocal += std.slow_files
+
+# User configuration
+
+DESTDIR ?=
+
+RM ?= rm -f
+RMDIR_P ?= rmdir -p
+TRUE ?= true