summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/20-var.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.once.head/20-var.mk')
-rw-r--r--build-aux/Makefile.once.head/20-var.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/build-aux/Makefile.once.head/20-var.mk b/build-aux/Makefile.once.head/20-var.mk
new file mode 100644
index 0000000..b1de987
--- /dev/null
+++ b/build-aux/Makefile.once.head/20-var.mk
@@ -0,0 +1,20 @@
+# Copyright 2015-2016 Luke Shumaker <lukeshu@sbcglobal.net>.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+var = $(patsubst ./%,%,$(topoutdir)/.var.)
+
+$(var)%: FORCE
+ @printf '%s' '$(subst ','\'',$($*))' | sed 's|^|#|' | $(WRITE_IFCHANGED) $@
+-include $(wildcard $(var)*)