summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/Makefile.each.tail/09-generate.mk1
-rw-r--r--build-aux/Makefile.head.mk8
-rw-r--r--build-aux/Makefile.once.head/09-generate.mk1
-rw-r--r--build-aux/Makefile.once.head/20-golang.mk30
-rw-r--r--build-aux/Makefile.once.head/20-var.mk20
5 files changed, 3 insertions, 57 deletions
diff --git a/build-aux/Makefile.each.tail/09-generate.mk b/build-aux/Makefile.each.tail/09-generate.mk
deleted file mode 100644
index 3a8566f..0000000
--- a/build-aux/Makefile.each.tail/09-generate.mk
+++ /dev/null
@@ -1 +0,0 @@
-$(outdir)/generate: $(std.gen_files)
diff --git a/build-aux/Makefile.head.mk b/build-aux/Makefile.head.mk
index e6b4a19..33ef9c1 100644
--- a/build-aux/Makefile.head.mk
+++ b/build-aux/Makefile.head.mk
@@ -13,8 +13,9 @@
# You should have received a copy of the GNU Affero General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
+at.Makefile ?= Makefile
_at.MAKEFILE_LIST ?=
-_at.MAKEFILE_LIST := $(strip $(_at.MAKEFILE_LIST) $(abspath $(lastword $(filter-out %.mk,$(MAKEFILE_LIST)))))
+_at.MAKEFILE_LIST := $(strip $(_at.MAKEFILE_LIST) $(lastword $(filter %/$(at.Makefile),$(abspath $(MAKEFILE_LIST)))))
# This bit only gets evaluated once, at the very beginning
ifeq ($(origin _at.NO_ONCE),undefined)
@@ -86,9 +87,6 @@ define at.nl
endef
-# External configuration ###############################################
-at.Makefile ?= Makefile
-
# Include modules ######################################################
include $(sort $(wildcard $(topsrcdir)/build-aux/Makefile.once.head/*.mk))
_at.tmp_targets =
@@ -102,7 +100,7 @@ endif # _at.NO_ONCE
outdir := $(call _at.path,$(dir $(lastword $(_at.MAKEFILE_LIST))))
ifeq ($(call _at.is_subdir,$(topoutdir),$(outdir)),)
-$(error Autothing: not a subdirectory of topoutdir=$(topoutdir): $(outdir))
+$(error Autothing: not a subdirectory of topoutdir=«$(topoutdir)»: «$(outdir)»)
endif
# Don't use at.out2src because we *know* that $(outdir) is inside $(topoutdir),
diff --git a/build-aux/Makefile.once.head/09-generate.mk b/build-aux/Makefile.once.head/09-generate.mk
deleted file mode 100644
index b07bb3f..0000000
--- a/build-aux/Makefile.once.head/09-generate.mk
+++ /dev/null
@@ -1 +0,0 @@
-at.phony += generate
diff --git a/build-aux/Makefile.once.head/20-golang.mk b/build-aux/Makefile.once.head/20-golang.mk
deleted file mode 100644
index 8e3835e..0000000
--- a/build-aux/Makefile.once.head/20-golang.mk
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 2015-2016 Luke Shumaker
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU Affero General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU Affero General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-golang.Q ?= @
-golang.FLAGS ?=
-
-_golang.cgo_variables = CGO_ENABLED CGO_CFLAGS CGO_CPPFLAGS CGO_CXXFLAGS CGO_LDFLAGS CC CXX
-$(foreach v,$(_golang.cgo_variables),$(eval $v ?=))
-export $(_golang.cgo_variables)
-
-_golang.src_cmd = find -L $1/src -name '.*' -prune -o \( -type f \( -false $(foreach e,go c s S cc cpp cxx h hh hpp hxx,-o -name '*.$e') \) -o -type d \) -print
-golang.src = $1/src $(shell $(_golang.src_cmd) 2>/dev/null)
-golang.var = $(addprefix $(var),$(_golang.cgo_variables))
-
-define golang.install
- GOPATH='$(abspath $1)' go install $(golang.FLAGS) $2
- $(golang.Q)true $(foreach e,$(notdir $2), && test -f $1/bin/$e -a -x $1/bin/$e && touch $1/bin/$e)
-endef
diff --git a/build-aux/Makefile.once.head/20-var.mk b/build-aux/Makefile.once.head/20-var.mk
deleted file mode 100644
index b1de987..0000000
--- a/build-aux/Makefile.once.head/20-var.mk
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 2015-2016 Luke Shumaker <lukeshu@sbcglobal.net>.
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU Affero General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU Affero General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-var = $(patsubst ./%,%,$(topoutdir)/.var.)
-
-$(var)%: FORCE
- @printf '%s' '$(subst ','\'',$($*))' | sed 's|^|#|' | $(WRITE_IFCHANGED) $@
--include $(wildcard $(var)*)