summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/config.mk b/config.mk
index 459318c..b5a63b2 100644
--- a/config.mk
+++ b/config.mk
@@ -12,8 +12,15 @@ shadow_file = $(sysconfdir)/nshd/shadow
NET ?=
#NET ?= FORCE
user = nshd
+
+# C
CFLAGS += -Wall -Wextra -Werror -pedantic
CC = gcc -std=c99
.LIBPATTERNS = lib%.so lib%.a
+# Go
+go_CC = gcc -std=gnu99
+GOCACHE = $(topoutdir)/go/cache
+CGO_ENABLED = 1
+
endif