summaryrefslogtreecommitdiff
path: root/src/nslcd/proto/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/nslcd/proto/Makefile')
-rw-r--r--src/nslcd/proto/Makefile59
1 files changed, 0 insertions, 59 deletions
diff --git a/src/nslcd/proto/Makefile b/src/nslcd/proto/Makefile
deleted file mode 100644
index e4730d5..0000000
--- a/src/nslcd/proto/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright (C) 2015 Luke Shumaker <lukeshu@sbcglobal.net>
-#
-# This library is free software; you can redistribute it and/or
-# modify it under the terms of the GNU Lesser General Public
-# License as published by the Free Software Foundation; either
-# version 2.1 of the License, or (at your option) any later version.
-#
-# This library is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this library; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
-# 02110-1301 USA
-
-d := $(patsubst %/,%,$(dir $(lastword $(MAKEFILE_LIST))))
-
-generate += $d/server/interface_backend.go
-generate += $d/server/func_handlerequest.go
-generate += $d/server/type_nilbackend.go
-secondary += $d/requests.txt
-
-ifeq (1,$(words $(MAKEFILE_LIST)))
-
-all: generate
-.PHONY: all
-
-generate: $(generate)
-.PHONY: generate
-
-clean:
- rm -f -- $(secondary)
-.PHONY: clean
-maintainer-clean: clean
- rm -f -- $(generate)
-.PHONY: maintainer-clean
-
-.DELETE_ON_ERROR:
-.SECONDARY:
-
-else
-
-# fix these to the current value of `d`
-generate := $(generate)
-secondary := $(secondary)
-
-endif
-
-$d/requests.txt: $d/nslcd_h.go $d/Makefile
- < $< grep -Eo '\btype Request_([^_ ]+)(_\S+)?' | sed 's/^type Request_//' > $@
-
-%.go: %.go.sh
- ./$^ > $@
-
-$d/server/interface_backend.go: $d/requests.txt
-$d/server/func_handlerequest.go: $d/requests.txt
-$d/server/type_nilbackend.go: $d/server/interface_backend.go