summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-15 01:42:27 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-15 01:42:27 -0500
commit319b45b070d5380f10a386f8eaa08214d6ad7aa7 (patch)
treeb2f14c2695d915679e2f94b2663fae0eb14d73b1
parent790698d078b8ee3c29ffd1a326e6bacefba4819f (diff)
improve libre/parabolaweb-utils
-rw-r--r--PKGBUILD4
-rw-r--r--parabolaweb-update9
2 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfdfc54..5fdd12b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=parabolaweb-utils
pkgver=`_get_pkgver`
-pkgrel=7
+pkgrel=8
pkgdesc="Utils for the Parabola website"
arch=('any')
url="https://projects.parabolagnulinux.org/parabolaweb.git/"
@@ -50,7 +50,7 @@ package() {
md5sums=('SKIP'
'f162c2ce49b4cafe0a14bd4767dfea04'
- '184f3e52781747369d8e26abc9723f7c'
+ '7c212024c134fdd0d0318b52a5448ddb'
'd5294495f42df29d29519ebd0a8f6093'
'cc15e153f99fba82e7bb032896f655c2'
'a468016a7155b5da46521dcfc6428384'
diff --git a/parabolaweb-update b/parabolaweb-update
index 1789176..2da9eea 100644
--- a/parabolaweb-update
+++ b/parabolaweb-update
@@ -18,7 +18,7 @@ clean() {
cd "$WEBDIR"
msg "Purging old .pyc files..."
find . -name '*.pyc' -delete
- msg "Purging GNU Make generated files..."
+ msg "Purging old GNU Make generated files..."
for dir in `find_makefiles`; do
make -C "$WEBDIR/$dir" clean
done
@@ -50,7 +50,7 @@ update-database() {
msg2 "Running migrations..."
./manage.py migrate
if [[ -f devel/management/commands/update_types_permissions.py ]]; then
- msg2 "Updating permission..."
+ msg2 "Updating permissions..."
./manage.py update_types_permissions
fi
msg2 "Loading fixtures..."
@@ -74,10 +74,11 @@ main() {
exit 1
fi
+ if [[ -d "$WEBDIR" ]]; then
+ clean
+ fi
parabolaweb-download
- clean
configure
- clean
update-database
update-filesystem
}