summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-14 16:11:14 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-14 16:11:14 -0500
commitc4124bfc9ffb7b6a6187620ef3d0e95bc763b8dc (patch)
treeab1298c8ed70e78a4239c8a0fa419f434a9d472f
parentb7c6c37081f1d1198b117cda1a0b7b9ec3f863f6 (diff)
update libre/parabolaweb-utils: make GITURL and GITREF configurable
-rw-r--r--PKGBUILD12
-rw-r--r--parabolaweb-download14
-rw-r--r--parabolaweb.conf2
3 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0b70ba..5000e02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=parabolaweb-utils
pkgver=`_get_pkgver`
-pkgrel=5
+pkgrel=6
pkgdesc="Utils for the Parabola website"
arch=('any')
url="https://projects.parabolagnulinux.org/parabolaweb.git/"
@@ -17,13 +17,15 @@ depends=(
'python2' # duh
'python2-flup' # for fcgi
'postgresql' # for database
- 'git' # used in parabolaweb-update
- 'libretools' # used in parabolaweb-update
+ 'git' # used in parabolaweb-download
+ 'libretools' # used in parabolaweb-{download,update}
`_get_depends`)
backup=('etc/conf.d/parabolaweb')
export pkgver
+makedepends=(makepkg-git)
+
source=(git://parabolagnulinux.org/parabolaweb.git
parabolaweb-download
parabolaweb-update
@@ -47,9 +49,9 @@ package() {
}
md5sums=('SKIP'
- '01bed679a4fd768e720bfd0f3c7d6694'
+ 'f162c2ce49b4cafe0a14bd4767dfea04'
'a73063b14746720b77fdbab851f5c161'
'd5294495f42df29d29519ebd0a8f6093'
'cc15e153f99fba82e7bb032896f655c2'
'a468016a7155b5da46521dcfc6428384'
- '9b565ef07e44d395bf7a0e484e3d19d1')
+ 'ffd37a19b1a72fbac2c58504aa17b355')
diff --git a/parabolaweb-download b/parabolaweb-download
index 823a188..e124295 100644
--- a/parabolaweb-download
+++ b/parabolaweb-download
@@ -4,8 +4,8 @@
. /usr/bin/libremessages
dir=$WEBDIR
-repo=git://parabolagnulinux.org/parabolaweb.git
-ref=master
+repo=$GITURL
+ref=$GITREF
cd_safe() {
if ! cd "$1"; then
@@ -26,11 +26,11 @@ download_git() {
else
cd_safe "$dir"
# Make sure we are fetching the right repo
- # if [[ "$repo" != "$(git config --get remote.origin.url)" ]] ; then
- # error "$(gettext "%s is not a clone of %s")" "$dir" "$repo"
- # plain "$(gettext "Aborting...")"
- # exit 1
- # fi
+ if [[ "$repo" != "$(git config --get remote.origin.url)" ]] ; then
+ error "$(gettext "%s is not a clone of %s")" "$dir" "$repo"
+ plain "$(gettext "Aborting...")"
+ exit 1
+ fi
msg2 "$(gettext "Updating %s %s repo...")" "${repo}" "git"
if ! git pull origin "$ref"; then
# only warn on failure to allow offline builds
diff --git a/parabolaweb.conf b/parabolaweb.conf
index 467e62e..5363479 100644
--- a/parabolaweb.conf
+++ b/parabolaweb.conf
@@ -2,3 +2,5 @@ HOST=127.0.0.1
PORT=8090 # 80 is nginx
WEBDIR=/srv/http/web
WEBUSER=nobody
+GITURL=git://parabolagnulinux.org/parabolaweb.git
+GITREF=master