summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-01-29 14:40:34 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-01-29 14:40:34 -0500
commit6ca7a10796da3afea4dee311b2f48d7190e02fd1 (patch)
treeb42cc986366de9ec3efe4b1dc00dc82fbbd4dd1d
parent9e7024c2798f429bcb76c5bb7a2131e1d2ae3ff4 (diff)
mv /etc/libretools.d/pbs{,-convert}.conf
-rw-r--r--Makefile6
-rw-r--r--pbs-convert.conf (renamed from config)1
-rwxr-xr-xpbs-plumb-config4
3 files changed, 5 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index c3ee3b2..96fe6b2 100644
--- a/Makefile
+++ b/Makefile
@@ -2,18 +2,18 @@ PREFIX=/usr/local
BINPROGS=$(shell find * -type f -executable)
-all: $(BINPROGS) config
+all: $(BINPROGS) pbs-convert.conf
install: $(addprefix $(DESTDIR)$(PREFIX)/bin/,$(BINPROGS)) $(DESTDIR)/etc/libretools.d/pbs.conf
uninstall:
for f in $(BINPROGS); do rm -f $(DESTDIR)$(PREFIX)/bin/$$f; done
- rm -f $(DESTDIR)/etc/libretools.d/pbs.conf
+ rm -f $(DESTDIR)/etc/libretools.d/pbs-convert.conf
$(DESTDIR)$(PREFIX)/bin/%: % | $(DESTDIR)$(PREFIX)/bin
install -m755 '$*' '${@D}'
-$(DESTDIR)/etc/libretools.d/pbs.conf: config | $(DESTDIR)/etc/libretools.d
+$(DESTDIR)/etc/libretools.d/pbs-convert.conf: pbs-convert.conf | $(DESTDIR)/etc/libretools.d
install -m644 '$*' '${@D}'
$(DESTDIR)$(PREFIX)/bin $(DESTDIR)/etc/libretools.d:
diff --git a/config b/pbs-convert.conf
index 85c8003..ee85bfa 100644
--- a/config
+++ b/pbs-convert.conf
@@ -2,7 +2,6 @@
cachedir = /var/cache/pbs
sourcedir = /var/pbs-sources
rewritedir = /var/pbs-rewrite
- treedir = /var/pbs
[source "arch-packages"]
type = absrepo
diff --git a/pbs-plumb-config b/pbs-plumb-config
index 87cf189..bbb733f 100755
--- a/pbs-plumb-config
+++ b/pbs-plumb-config
@@ -15,7 +15,7 @@ list() {
# stdout: The raw value of SETTING in FILE; *not* terminated by a newline
##
get() {
- [[ $# != 2 ]] && { usage; return 1; }
+ [[ $# != 2 ]] && { usage; return 1; }
local file=$1
local setting=$2
git config --file "$file" -z --get "$setting"
@@ -26,7 +26,7 @@ main() {
local cmd=$1
shift
- local file="/etc/libretools.d/pbs.conf"
+ local file="/etc/libretools.d/pbs-convert.conf"
case "$cmd" in
list)
list "$file" "$@"