summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-26 15:07:16 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-26 15:07:16 -0500
commite34aed84b17c99fcf286e5d5f212374f335902e4 (patch)
treeb0be4b2e7d9f7a03b0e9b0323ba1708de77ee190 /Makefile
parent648afbb3c2aad1d352e4795bfa2f068b9191eb9a (diff)
fix location of the config file
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..c3ee3b2
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,20 @@
+PREFIX=/usr/local
+
+BINPROGS=$(shell find * -type f -executable)
+
+all: $(BINPROGS) config
+
+install: $(addprefix $(DESTDIR)$(PREFIX)/bin/,$(BINPROGS)) $(DESTDIR)/etc/libretools.d/pbs.conf
+
+uninstall:
+ for f in $(BINPROGS); do rm -f $(DESTDIR)$(PREFIX)/bin/$$f; done
+ rm -f $(DESTDIR)/etc/libretools.d/pbs.conf
+
+$(DESTDIR)$(PREFIX)/bin/%: % | $(DESTDIR)$(PREFIX)/bin
+ install -m755 '$*' '${@D}'
+
+$(DESTDIR)/etc/libretools.d/pbs.conf: config | $(DESTDIR)/etc/libretools.d
+ install -m644 '$*' '${@D}'
+
+$(DESTDIR)$(PREFIX)/bin $(DESTDIR)/etc/libretools.d:
+ install -d '$@'