summaryrefslogtreecommitdiff
path: root/community/liteide/PKGBUILD
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@endefensadelsl.org>2014-07-26 03:59:52 +0000
committerNicolás Reynolds <fauno@endefensadelsl.org>2014-07-26 03:59:52 +0000
commit3f8fdc60f0dbd72d350af3927657f9ff97eb249f (patch)
tree65ccd3339fb817893cfd5189826d671a3303385a /community/liteide/PKGBUILD
parent29cefdccedfcb48822a8da80b259ed0bb0f73266 (diff)
Sat Jul 26 03:49:34 UTC 2014
Diffstat (limited to 'community/liteide/PKGBUILD')
-rw-r--r--community/liteide/PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/community/liteide/PKGBUILD b/community/liteide/PKGBUILD
index 0f09d2f22..1e9525477 100644
--- a/community/liteide/PKGBUILD
+++ b/community/liteide/PKGBUILD
@@ -1,12 +1,12 @@
-# $Id: PKGBUILD 113424 2014-06-22 12:27:45Z arodseth $
+# $Id: PKGBUILD 116338 2014-07-25 14:02:29Z arodseth $
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
# Contributor: spambanane <happy.house@gmx.de>
# Contributor: Matteo <matteo.dek@gmail.com>
# Contributor: Matthew Zimmerman <mzimmerman@gmail.com>
pkgname=liteide
-pkgver=22
-pkgrel=3
+pkgver=23
+pkgrel=1
pkgdesc='IDE for editing and building projects written in the Go programming language'
license=('LGPL')
arch=('x86_64' 'i686')
@@ -24,9 +24,12 @@ md5sums=('SKIP'
prepare() {
gendesk -f -n --name 'LiteIDE' --pkgname "$pkgname" --pkgdesc "$pkgdesc"
chmod +x "liteide-x$pkgver/build/"*_*.sh
+
# Fix for FS#4662 until fixed by upstream
- sed -i 's/GOROOT/#GOROOT/g' "liteide-x$pkgver/liteidex/os_deploy/linux/liteenv/linux32.env"
- sed -i 's/GOROOT/#GOROOT/g' "liteide-x$pkgver/liteidex/os_deploy/linux/liteenv/linux64.env"
+ for bits in 32 64; do
+ sed -i 's/GOROOT/#GOROOT/g' \
+ "liteide-x$pkgver/liteidex/os_deploy/linux/liteenv/linux$bits.env"
+ done
}
build() {
@@ -39,11 +42,6 @@ build() {
./update_pkg.sh
./build_linux.sh
-
- # Fixing insecure RPATH, need to test if this is still needed
- cd ../liteidex
- find . -name "*.so" -type f -exec sed -i 's|/home/win|/usr/lib/|g' {} \;
- find . -name liteide -type f -exec sed -i 's|/home/win|/usr/lib/|g' {} \;
}
package() {
@@ -68,7 +66,6 @@ package() {
msg2 'Packaging libraries and plugins...'
cp -r liteide/lib/liteide/* "$pkgdir/usr/lib/liteide"
- cp -r liteide/bin/libliteapp.* "$pkgdir/usr/lib/"
chmod -x "$pkgdir/usr/lib/liteide/plugins/"*
msg2 'Packaging license and license exception...'