summaryrefslogtreecommitdiff
path: root/community/aria2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/aria2/PKGBUILD')
-rw-r--r--community/aria2/PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/community/aria2/PKGBUILD b/community/aria2/PKGBUILD
index fdfba60cc..41502f8c3 100644
--- a/community/aria2/PKGBUILD
+++ b/community/aria2/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 116175 2014-07-23 16:15:57Z fyan $
+# $Id: PKGBUILD 116412 2014-07-27 08:00:32Z fyan $
# Maintainer: Felix Yan <felixonmars@gmail.com>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Thomas Dziedzic < gostrc at gmail >
@@ -8,15 +8,24 @@
pkgname=aria2
pkgver=1.18.7
-pkgrel=1
+pkgrel=2
pkgdesc='Download utility that supports HTTP(S), FTP, BitTorrent, and Metalink'
arch=('i686' 'x86_64')
url='http://aria2.sourceforge.net/'
license=('GPL')
depends=('gnutls' 'libxml2' 'sqlite' 'c-ares' 'ca-certificates')
checkdepends=('cppunit')
-source=(http://downloads.sourceforge.net/aria2/aria2-$pkgver.tar.xz)
-sha256sums=('7944336efdfc82892802bec304698448e8d27b30f30496576716e8b93ebfff98')
+source=("http://downloads.sourceforge.net/aria2/aria2-$pkgver.tar.xz"
+ https://github.com/tatsuhiro-t/aria2/commit/c659fe939df2b0830f83f39429d6e7814ac82157.patch)
+sha256sums=('7944336efdfc82892802bec304698448e8d27b30f30496576716e8b93ebfff98'
+ '1225cde7db20d185188de752edebd4f76c73e4806793d7d139031788bf9434eb')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # https://github.com/tatsuhiro-t/aria2/issues/265
+ patch -p1 -i ../c659fe939df2b0830f83f39429d6e7814ac82157.patch
+}
build() {
cd $pkgname-$pkgver